Back to LanguageTool Homepage - Privacy - Imprint

Building LanguageTool 3.1 failure


(Rick Meyer) #1

I am trying to build LanguageTool3.1 (mvn compile), but I get the following error:

[ERROR] Failed to execute goal on project language-en: Could not resolve dependencies for project org.languagetool:language-en:jar:3.1: Failure to find org.languagetool:languagetool-core:jar:tests:3.1 in http://repo.adobe.com/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of adobe has elapsed or updates are forced -> [Help 1]

When I look at http://repo.adobe.com/nexus/content/groups/public/ I cannot find any reference to org.languagetool there. Am I doing something wrong?

We are still using Java7, so I cannot upgrade to 3.2.

What I am trying to accomplish is to get a standalone version of LanguageTool to integrate into our webapp that has uses HunspellRule for French and Portuguese, instead of HunspellNoSuggestionRule. If there is a better way to do this please let me know.

Thanks,

Rick Meyer


(Daniel Naber) #2

Do you call mvn compile in LT's top-level directory? Also, could you try mvn install instead (again, in LT's top-level directory)? If that doesn't help, which version of Maven do you use?


(Rick Meyer) #3

Trying mvn install got much further. This time I got the following error message:

[INFO] Hunspell native libs for LanguageTool .............. SUCCESS [ 0.303 s]
[INFO] LanguageTool Wikipedia tools ....................... SUCCESS [ 44.818 s]
[INFO] LanguageTool development tools ..................... FAILURE [01:09 min]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 06:55 min
[INFO] Finished at: 2016-01-07T14:31:13-05:00
[INFO] Final Memory: 66M/284M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.2:compile (default-compile) on project languagetool-dev: Fatal error compiling: invalid target release: 1.8 -> [Help 1]

I'm compiling with Java7. I thought 8 wasn't required until the current LangauageTools version 3.2.
The version of maven I have installed is 3.3.3, btw.


(Daniel Naber) #4

Java 8 actually was required for building, but not for using LT. If you don't need languagetool-dev, you can just remove it from the top-level pom.xml. I think it's the only module needing Java 8 for compilation.


(Rick Meyer) #5

Good to know. Thanks.