Back to LanguageTool Homepage - Privacy - Imprint

[DE] "LanguageTool-Bug"


(Knorr) #4

Nur zur Info: Ich habe mich bislang nicht mit dem Libreoffice-Plugin besch├Ąftigt und plane auch nicht, es zu tun. Es m├╝sste sich also jemand anderes dieses Problems annehmen


(Jeremy S.) #5

Wer besch├Ąftigt sich denn damit, damit ich ihn direkt ansprechen kann?


(Knorr) #6

Wei├č ich auch nicht!
In einem Open-Source-Projekt gibt es nicht notwendigerweise einen eindeutigen Ansprechpartner.
@Fred.Kruse hat sich meines Wissens mit dem Plugin in der Vergangenheit besch├Ąftigt.


(Jeremy S.) #7

@Fred.Kruse w├╝rde mich freuen, wenn er ist, denn ihn kenne ich immerhin.

Gr├╝├če Dallun511


(Fred Kruse) #8

Gibt es einen Text (m├Âglichst kurz), in dem der Fehler regelm├Ą├čig auftritt, den du mir zuschicken k├Ânntest, um ihn zu testen.
Es liegt nicht an der 6er Version von LO. Ich arbeite mit der 6.2 alpha und dieser Fehler ist mir bislang nicht untergekommen.
Noch ein paar andere Fragen:
Hast du mehrere Dokumente gleichzeitig ge├Âffnet?
Tritt der Fehler aus, nachdem du an dem Absatz etwas ge├Ąndert hast?
Tritt der Fehler auf nachdem du an dem Absatz davor oder dahinter etwas ge├Ąndert hast?


(Jeremy S.) #9

grafik


LanguageTool-Analyse-Bug 2018-10-07.zip (37.4 KB)

  1. Nein hatte ich nicht. Ich hatte manchmal zwei Dokumente gleichzeichtig offen, aber nicht immer. In diesem Dummybeispiel war nur dieses eine Dokument offen.

  2. Ja kommt er, aber auch nachdem ich den Satz vollendet habe, also einen neuen Satz geschrieben habe.

  3. Ja kommt er ebenfalls. Wenn ich mittendrin was ver├Ąndere, erscheint der Fehler.


(Jeremy S.) #10

@Fred.Kruse hast du Nachricht erhalten, womit du das Zip-Archiv ├Âffnen kannst?

Gr├╝├če Dallun511


(Fred Kruse) #11

@Dallun511 die Nachricht habe ich nicht erhalten. Glaube aber den Fehler aufgrund eigener Tests gefunden zu haben. Teste die neu Version (ab morgen) mal und gib eine R├╝ckmeldung, ob der Fehler jetzt noch auftritt.


(Jeremy S.) #12

Dann werde heute die neue Version testen, welche heute um 22 Uhr erscheint, die du wahrscheinlich meinst. Ich habe dir eine Privatnachricht ├╝ber das Forum geschrieben, was wohl nicht angekommen ist, was ich komisch finde, aber wenn du trotzdem den Fehler behoben hast, ist das nicht schlimm.

Ich werde es heute Abend sehen.

Gr├╝├če Dallun511


(Jeremy S.) #13

grafik
@Fred.Kruse Ich kann den neuen Snapshot nicht installieren :frowning:


Java ist richtig installiert.

merkw├╝rdig, ich kann keine LT-Version installieren, aber die Standalone-Version funktioniert.


(Jeremy S.) #14

@Fred.Kruse Das Problem ist leider weiterhin vorhanden.
grafik

Mit LibreOffice 6.1 Portable und der neusten LanguageTool-Version von 12.10.2018 getestet.


Ein Satz geschrieben und schon kam der Fehler.

Gr├╝├če Dallun511


(Jeremy S.) #15

grafik

Jetzt mit LibreOffice 6.1.2 und des neusten Snapshot von 13.10.2018 getestet.

Gr├╝├če Dallun511


(Jeremy S.) #16

@Fred.Kruse wie lautet deine E-Mailadresse, dann schicke ich dir das Zip-paket direkt, oder m├Âchte noch jemand das Zip-Paket?


(Fred Kruse) #17

Wenn ich es richtig sehe, wird der Fehler durch ein Verhalten von LibreOffice erzeugt. Das Officepaket meldet in bestimmten Situationen eine ├änderung an einem Absatz nicht an LT weiter. Zusammen mit dem in der LT-Extension installierten Cache-Mechanismus f├╝hrt das zu Unterstreichungen an falscher Stelle oder auch zu einem ÔÇśMerkenÔÇÖ eines falschen Fehlerstandes.
In der gerade eingespielten Version habe ich eine Hilfsl├Âsung eingef├╝hrt, die den Fehler beheben sollte. Bei langen Texten kann es allerdings sein, dass sich der Fehler erst kurz zeigt und dann wieder verschwindet. Bitte teste es mal, nachdem der neue Snapshot morgen zur Verf├╝gung steht.


(Jeremy S.) #18

Werde ich machen und wenn es nur kurz da ist und nach einer Minute wieder verschwindet, w├Ąre ich zufrieden, denn bisher war es permanent, was sehr nervig.


(Jeremy S.) #19


Die Meldung verschwindet erst, nachdem ein neuer Satz angefangn wird und nicht vorher, aber das blaue bleibt permanent, was nicht gut ist.

grafik

ÔÇťwenn man auf ÔÇťeinmal ignorierenÔÇŁ klickt, wird nichts mehr gefunden.ÔÇŁ Das ist gut, wenn auch der blaueunterstrichende Text mal verschwinden w├╝rde.

Gr├╝├če Dallun511


(Jeremy S.) #20

@Fred.Kruse arbeitest du noch an diesem Problem oder ist das Problem zurzeit in der To-Do-Liste?

Gr├╝├če Dallun511


(Fred Kruse) #21

Das Problem sollte bereits seit einigen Tagen behoben sein.


(Jeremy S.) #22

Ich werde mich die Ergebnisse dieses Woche ansehen und berichtet erstatten, ob das Problem vom Tisch ist oder nicht.

Gr├╝├če Dallun511


(Jeremy S.) #23

Ich kann bisher best├Ątigen, dass das Problem behoben wurde. Die blau unterstrichende Textstellen verschwinden nach kurzen Zeitabst├Ąnden und es gibt auch keine f├Ąlschlichen Fehlermeldungen.

Gr├╝├če Dallun511