Back to LanguageTool Homepage - Privacy - Imprint

[DE]LT-de Wörterbuch?

Meine Wörter sind vorhanden, obwohl ich sie nie eingetragen habe. Sie sind in meinem Wörterbuch, das auf der Festplatte gespeichert. Das ist doppelt gespeichert.

Zudem ist laut LibreOffice das Wörterbuch nur für Deutsch (Luxenburg) zuständig. Ich schreibe Deutsch (Deutschland), womit das Wörterbuch keinen Nutzen bei mir und vermutlich auch bei anderen Usern findet.

Nach meiner Meinung sollte es eine Möglichkeit geben, diese Funktion zu deaktiveren. Zumindest mein Wunsch.
Eine andere Möglichkeit könnte sein, dass das Wörterbuch auch nur für die Sprachen verfügbar ist, die vom User benutzt werden.

Als Beispiel:
Das LanguageTool erstellt ein Wörterbuch das für LibreOffice “Englisch (Großbritanien)” zuständig ist. Aber der User schreibt nur “Deutsch (Deutschland)” Dann bringt das den User keine Vorteile, sondern eher Nachteile, da das LanguageTool unnötige Last den System zumutet. Einige User wollen diese Funktion deaktivieren, geht aber nicht.

Zweites Beispiel:
Das LanguageTool prüft die Hauptsprache des Dokumentes und erkennt. Der User nutzt “Deutsch (Deutschland)”, also muss mein Wörterbuch auch “Deutsch (Deutschland)” sein, weil der User sonst keinen Nutzen daraus ziehen. Der Nutzer erkennt, dass das LanguageTool dieses Wörterbuch für die Analyse braucht oder einen Vorteil darauszieht.
Und so sollte das LanguageTool vorgehen.

Ein Wörterbuch, dass mir nichts bringt, lösche ich. Das halt das System sauber. Ich installiere nur gern das, was ich auch wirklich brauche.

@Fred.Kruse ist es möglich, dem LanguageTool eine Option zu geben, um diese Funktion abzustellen? Und ist es möglich, dass das virtuelle Worterbüch auch die Sprache nutzt, die der User nutzt?
Z. B. LO-Dokument “Deutsch (Deutschland)” LT-Wörterbuch “Deutsch (Deutschland)”
Die erste Fuktion wäre mir lieber. Ganz ehrlich. Aber die zweite Funktion würde allen Usern helfen, da ich hier die Vorteile sehe, weil dann LibreOffice auch das Wörterbuch nutzt.

Grüße Dallun511


Hier ein Bild, um zu zeigen, dass das Wörterbuch in dieser Einstellung keinen Nutzen hat, wenn das Dokument auf “Deutsch (Deutschland)” ist.

Im Wörterbuch ist “B-Black” eingetragen, aber LibreOffice nutzt das Wörterbuch nicht, weil es auf “Deutsch (Luxenburg)” gestellt ist.

Um noch mal die Funktion deutlich zu machen:
Die LT-Erweiterung für LO/OO prüft nicht die Rechtschreibung. Diese Funktion bleibt bei LO bzw. OO. LT benutzt von den Entwicklern per Hand erstellte Textdateien, um den Sprachumfang des Standard-Wörterbuchs zu erweitern. Diese Worte werden jetzt automatisch in ein internes Wörterbuch geladen, damit auch die Rechtschreibprüfung von LO/OO diese Worte kennt.

Aus einem mir nicht ganz verständlichen Grund wurde bei dir als Land Luxemburg eingestellt. Das liegt womöglich daran, dass ich das Land indirekt ermittelt hatte. Ich habe das jetzt geändert. Es wird jetzt genau die Kombination aus Sprache und Land an das Wörterbuch übermittelt, die auch für die Grammatikprüfung benutzt wird. Wenn nach dem nächsten Update bei dir noch immer Luxemburg steht, hast du entweder eine falsche Sprache eingestellt oder LO hat einen Fehler.

Außerdem habe ich den Namen geändert. Das Wörterbuch sollte jetzt __LT_de_internal.dic heißen. Damit wird hoffentlich deutlich, dass es eine Systemdatei ist. Leider habe ich keine Möglichkeit gefunden zu verhindern, dass sie angezeigt wird.

Bei mir ist alles deutsch, aber LO traue ich vieles zu. Ich werde Bescheid geben, wenn immer noch Luxenburg bei mir steht.

Warum sind dann meine Wortneuschöpfungen in dieser Liste? Oder liege ich richtig, dass das Wörterbuch, die Wörter aus der Added.txt extrariert und einfügt?

Grüße Dallun511


In der neusten Version ist das Wörterbuch auf “Deutsch (Deutschland)” ausgerichtet.

Weiterhin werden meine Wortneuschöpfungen aufgelistet.
Leider auch keine Option, das Worterbüch zu deaktivieren.
Viele der Wörter in diesem Wörterbuch sind in meinen Benutzerwörterbüchern vorhanden oder brauche ich nicht. Deswegen wünsche ich mir auch eine Option das abzustellen.

Grüße Dallun511

P.S. Den Hacken herauszunehmen bringt nichts. Aber das wurde mir auch gesagt, dass es wieder neu erstellt wird, weil es virtuell ist.

Das virtuelle Wörterbuch enthält jetzt nur noch die Worte, die LO aus anderen Wörterbüchern nicht kennt. Bitte teste das noch mal ab morgen.

1 Like

Das hört sich interessant an und ich hoffe, dass auch die Wörter herausgenommen werden, denn eine doppelte Speicherung ist wirklich sinnlos.


Meine Wörter sind weiterhin vorhanden.

@Fred.Kruse ich habe zwei wichtige Fragen zum LT-Wörterbuch.

Werden die Wörter aus der added.txt in das virtuelle Wörter eingetragen?
Und wird es eine Fuktion geben, um diese Funktion komplett abzuschalten oder zumindes temporär?

Ich würde mich freuen, wenn du mir diese Fragen beantworten könntest.

@Dallun511: Die Wörter werden aus dem added.txt eingetragen. Ab morgen zusätzlich auch aus dem hunspell/spelling.txt.
Bisher plane ich nicht, dass die Funktion optional ausgeschaltet werden kann. Die Worte, die in dem Standardwörterbuch oder in einem, das du lokal hinzugefügt hast, stehen, werden nicht in das LT-Wörterbuch geschrieben.
Es geht darum, dass die Wörter, die LT kennt und in seinen Regeln berücksichtigt, nicht als Rechtschreibfehler markiert werden.

Wenn du keine Option einfügst, um die Option abzuschalten, kannst du zumindest bitte eine Option einfügen, um das virtuelle Wörterbuch in ein Textdokument zu extrarieren, damit ich nach sehen kann, welche Wörter das Wörterbuch “Deutsch (Deutschland)” von Hausaus nicht kennt.

Ich sammel schließlich Wörterlisten für die Entwickeler. Das ist der Grund, warum ich am liebsten eine Option haben möchte, um es komplett abzuschalten. Denn dann werden Wörter, die das Wörterbuch nicht kennt, sofort Rot unterstrichen, wenn jetzt aber das virtuelle Wörterbuch dieses Wort kennt, würde ich es nicht bemerken und könnte das Wort in meine Wörterliste nicht eingetragen.

Mit einem Textdokument, dass alle Wörter des virtuellen Wörterbuches beinhaltet, brauche ich nur ins Textdokument schauen und vergleichen. Das wäre immer noch ein Umweg, aber eine gute Mittellösung, wenn für dich die vollständige Deaktierung nicht möglich ist.

Mit freundlichen Grüßen
Dallun511 Ferewo

Ich habe jetzt eine Option unter LanguageTool / Optionen eingebaut, mit der du das interne Wörterbuch abschalten kannst. Du findest sie als letzten Punkt im Tab “Allgemeines” (ist noch auf Englisch). Wenn du den Haken rausnimmst, wird das Wörterbuch gelöscht und nicht wieder geladen (bis du ihn wieder setzt).

1 Like

Ob Englisch oder Deutsch, solange sie funktioniert ist mir das egal.

Ich bedanke mich sehr herzlich, dass du diese Funktion einbaust.


Nur als Hinweis, das Deaktieren führ sofort zum Aufhängen des Programms.
Nach dem Abstürz ist wieder alles normal.

Das Wörterbuch ist ein temporäres, virtuelles (nur im Speicher), das all diejenigen Wörter enthält, die von LT für die Grammatikprüfung hinzudefiniert worden sind. Es geht darum, dass ein Wort, das die Grammatikprüfung als korrekt erkennt, nicht durch die LO-Rechschreibprüfung als fehlerhaft angenommen wird.

ich finde es schön, dass du dich für diesen Artikel interessiert, nur solltest du dir vorher alle Einträge des Artiekls durchlesen, denn mir wurde schon bereits gesagt, für was das Wörterbuch ist. Ich wollte es nur abschalten, weil ich Wörter für die Entwickler des Wörterbuchs sammel, woran mich dieses Worterbuch von LT behindert.

Grüße Dallun511

Thanks .

Das Wörterbuch ist ein temporäres, virtuelles (nur im Speicher), das all diejenigen Wörter enthält, die von LT für die Grammatikprüfung hinzudefiniert worden sind. Es geht darum, dass ein Wort, das die Grammatikprüfung als korrekt erkennt, nicht durch die LO-Rechschreibprüfung als fehlerhaft angenommen wird.

@dnaber Bitte schließe diesen Beitrag, denn es stört mich, dass jeder mir erklärt, wie deses Wörterbuch funktioniert, obwohl das @Fred.Kruse schon erklärt hat und später gar nicht mehr Thema war.

@Dallun511 Du kannst hier selber einstellen, ob/welche Benachrichtigungen du bekommen willst:

screenshot-2020-08-01-14:49

1 Like