Back to LanguageTool Homepage - Privacy - Imprint

Esperanto: "Movi kategorion"


(Guillermo) #1

La frazo "Movi kategorion" estas korekte laŭ LanguageTool retejo, sed ĝi havas eraron se mi uzas la komplementon por LibreOffice:
Oni prekaŭ ĉiam uzas la verbon Movi kun akuzativo. Ĉu vi intencis Moviĝi?


(Dominique PELLÉ) #2

Saluton Guillermo / Hi Guillermo

[eo] Mi ne vidas tiun falsan eraron, nek per LibreOffice+LanguageTool-2.6.oxt, nek ĉe http://www.languagetool.org/eo/
Kiun version de Lingviilo (LanguageTool) vi uzas?

[en] I do not see this false error, neither with LibreOffice+LanguageTool-2.6.oxt, nor using http://www.languagetool.org/eo/
Which version of LanguageTool are you using?


(Guillermo) #3

Mi uzas la version 2.6 en LibreOffice: LanguageTool 2.6 (2014-06-30 13:20)

Ekrankopio de la eraro:

Certe, mi eraris, finante en 58 kaj ne estas 158 la IP-adreso.


(Dominique PELLÉ) #4

[eo] La ligiilo ne funkcias. Pli bonas enmeti la bildon en la forumo. Kio estas la tuta frazo, kun la malvera eraro?

[en] The link is broken. It's better to embed the picture in the forum. What is the whole sentence with the false error?


(Guillermo) #5

Certe, mi eraris, finante en 58 kaj ne estas 158 la IP-adreso.


(Dominique PELLÉ) #6

[en] I could finally reproduce your error by looking at your screenshot which I embed here:


Typing this in LibreOffice (with Esperanto language) is enough to reproduce the problem:

Moviĝu kategorion
Movi kategorion

LanguageTool gives the false error underlining "Movi".
Strangely, I do not see this false error in the command line version of LT-2.6 or daily build.
I do not see it either on the website https://www.languagetool.org/eo/ either.
So it seems to be a LibreOffice bug!? But I need to look further.

However, one important remark: you entered several sentences without dot.
This confuses LanguageTool as it rightfully treats consecutive line as the same
sentence. If I instead type:

Moviĝu kategorion.
Movi kategorion.

... then LT-2.6 has no false error anymore in LibreOffice and correctly detects the
error in the first sentence.

But it's still unexpected that only LibreOffice gives a false error without dot,
which is not seen in the command line or on the web demo. So I created this bug:

[eo] Mi finfine povis vidi vian problemon vidinte vian ekrankopion, kiun
mi enmetis ĉi tie.

Tajpu tion sufĉas por vidi falsan eraron:

Moviĝu kategorion
Movi kategorion

Mi strange ne vidas la malveran eraron per la komanda linio de LT-2.6 aŭ per la plej freŝa version en github.
Mi nek vidas la falsan eraron en la retejo https://www.languagetool.org/eo/
Do ŝajnas esti cimo en LibreOffice. Mi devas plu rigardi la aferon.

Tamen, jen grava rimarko: vi tajpis frazojn sen fina punkto.
Tio konfuzas Lingvoilon, ĉar ĝi ĝuste konsideras la 2 fazojn kiel nur
unu frazo. Se vi anstataŭ tajpas:

Moviĝu kategorion.
Movi kategorion.

Tiam lingvoilo-2.6 ne plu donas malveran eraron,kaj ĝuste vidas la veran eraron en la unua frazo.

Sed estas tute neatendita, ke nur LibreOffice donas malveran eraron sen la finaj punktoj,
kaj ne en komanda linio, kaj ne en la retejo. Do mi kreis tiun cimon: