Back to LanguageTool Homepage - Privacy - Imprint

"File is already locked"

(Marco A.G.Pinto) #1


I am getting this error when I try to update files:
C:\Users\marcoagpinto\Desktop\LanguageTool Repo GITHUB (Trunk) 2016-01-05\languagetool-language-modules\pt\src\main\resources\org\languagetool\resource\pt

Is there a way to fix it?


(Daniel Naber) #2

It probably means you have the file open in some editor etc. If you close it, the update should work.

(Marco A.G.Pinto) #3

I rebooted the computer and it still doesn’t work:

(Daniel Naber) #4

It says to run the “cleanup” command, have you tried that? What software is this anyway, the official github client?

(Jan Schreiber) #5

It looks like TortoiseSVN, an SVN (sic!) client that also supports git.
@marcoagpinto Right-click the folder on your desktop, and from the context menu, choose the command that says “clean up” or something like that, as Daniel said. This always worked for me.

(Marco A.G.Pinto) #6

I can’t find any option “clean up”:

(Jan Schreiber) #7

This is the context menu for a file. Maybe the command only shows up when you’re on a folder. Go to your desktop and right-click the folder “LanguageTool Repo …”. If that doesn’t help, I don’t know. Try googling the error message. It is a common problem with TortoiseSVN.

If nothing helps, copy your changed files to some other folder and do a fresh checkout. Good luck, soldier! You’re on your own now.

(Marco A.G.Pinto) #8


It worked!

Thank you!

(Tiago F. Santos) #9

Hi @marcoagpinto,

I have noticed this now. It may have happened because I pushed changes to GitHub while you had ‘uncommitted’ changes in your computer. If so, this has happened to me before. I know only git terms, but SVN has equivalent functions, so you can solve that by doing ‘commits’ with all you local changes, then ‘pull’ GitHub changes (‘rebase’ is important), and finally ‘push’ the changes to GitHub. I am not fluent with SVN so I won’t even try to ‘translate’ the terms to that, but they do exist.