Back to LanguageTool Homepage - Privacy - Imprint

"Ignore once" in OpenOffice 4.1.0 / LanguageTool 2.6


(Tina) #1

Hello,

I'm having trouble with the grammar checking in OpenOffice Writer (4.1.0).

I get the usual dialog for the spell-checking and it works fine when using "ignore once". For the grammar checks with LanguageTool this doesn't work anymore. I already removed and added the Extension again, checked my Java (7 Update 60) and even re-installed OpenOffice. But I can't move past the point of the first grammar error in OpenOffice. When I click the "ignore once" button the window flickers a bit, but nothing happens. It doesn't go to the next spell- or grammar error. [I'm using Win7].

Is there a bug? What else could the problem be?

Thanks,
Tina


(Daniel Naber) #2

Thanks for your bug report. I can reproduce the problem. This seems to be a very old issue that has come back... we'll be tracking it at https://github.com/languagetool-org/languagetool/issues/125, although the fix will probably need to be applied to OpenOffice.


(Daniel Naber) #3

A simple workaround seems to be to enable AutoSpellcheck (the mode that underlines errors) before you check your text.


(Tina) #4

Good to see that it's truly a bug (come back) an not just some weird behavior on my computer.

Unfortunately though, auto-spellcheck does not seem to "solve" the problem for me. I tried both German and English texts, but even with auto-spellcheck enabled, it doesn't move past the grammar errors with "Ignore once". As a matter of fact, it does not underline grammar errors in blue either.


(Daniel Naber) #5

LanguageTool takes some time to start up, so please make sure to wait a bit (maybe 5-20 seconds) after you have activated AutoSpellcheck. If errors are still not underlined by LT, something else is wrong. Can you send a short example document so I can try to reproduce the issue?


(Tina) #6

Yes, I know it can take some time to start or auto-check a text, especially if it's longer.

I de-installed and re-installed both OpenOffice and LanguageTool again today, but I also cleared the Java Cache and - probably more importantly - killed the OpenOffice AppData stuff. I also deleted the LanguageTool config file.
Now I have the same situation as you do. "Ignore once" doesn't work, as long as I have auto-spellcheck off.