Back to LanguageTool Homepage - Privacy - Imprint

Installing LanugageTool in LibreOffice


I failed to install Languagetool to Libreoffice. I tried languagetool stable and nighly (as of today) with libeoffice trunk (from yesterday) and on Ubuntu 13.10 amd64. I get the following error:

( { { Message = “[jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 51.0\X000ajava stack trace:\X000ajava.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 51.0\X000a\X0009at java.lang.ClassLoader.defineClass1(Native Method)\X000a\X0009at java.lang.ClassLoader.defineClass(\X000a\X0009at\X000a\X0009at\X000a\X0009at$000(\X000a\X0009at$\X000a\X0009at Method)\X000a\X0009at\X000a\X0009at java.lang.ClassLoader.loadClass(\X000a\X0009at java.lang.ClassLoader.loadClass(\X000a\X0009at\X000a\X0009at java.lang.ClassLoader.loadClass(\X000a\X0009at\X000a\X0009at\X000a”, Context = ( @0 } }

Any ideas?


You need Java 7 or 8 - you’re using Java 6. Java 7 or 8 needs to be both installed on your system and configured in LibreOffice (Tools -> Options -> Advanced).

Check synaptic for the meta-package “libreoffice”. It contains serveral java-related packages and installing it solved the problem for me on Linux Mint 14.