Back to LanguageTool Homepage - Privacy - Imprint

LanguageTool-4.5.1 crashes LibreOffice

Hi,

LanguageTool-4.5.1 crashes LibreOffice 5.2.7.2 on Linux reproducibly - every time - on two different computers. First one is 64bit, second one is 32bits.

Operatingsystem:

Linux, Debian (Stable, version 9)
Java: OpenJDK 8 (8u212-b01-1~deb9u1)

This does NOT happen with LanguageTool 3.7.

Steps to reproduce:

  1. Make a new LibreOffice profile in /home/user/.config/
  2. Start LO
  3. Install LanguageTool-4.5.1 via extension manager
  4. Type something and then hit the print-preview-button

Errormessage:
libreoffice --writer

X Error: BadMatch (invalid parameter attributes) 8
Major opcode: 42 (X_SetInputFocus)
Resource id: 0x3a01318
error
xsltParseStylesheetFile : cannot parse
I/O warning : failed to load external entity “”
error
xsltParseStylesheetFile : cannot parse
error
xsltParseStylesheetFile : cannot parse
I/O warning : failed to load external entity “”
error
xsltParseStylesheetFile : cannot parse
SLF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.

Are you sure this is caused by LT, it does it not crash when LT is not installed? Only the last three items in your output seem to come from LT, but they are harmless and can hardly cause a crash.

I remember having this exact same issue on the latest of both of them, when i was on Ubuntu on my bad laptop, it went completely ¨corrupted¨ after installation.
So, I’ve film the installation of the extension, on a freshly installed LibreOffice expecting the same issue. Strangely, no issue there.

Yes, I am 100% sure that it has to do with LT-4.5.1.

Without it, LibreOffice is rock stable.

It is also rock stable with LT 3.7.

But as soon as I install LT 4.5.1 it crashes EVERY TIME.

As described in my initial post, I tested it on 2 different machines with a clean, new LO profile.

Please feel free to reproduce it by following my steps to reproduce. However I do not know if it would also crash inside a VM since I am only using bare metal installations.

Same here.

Using LibreOffice 5.2.7.2 on LinuxMint Debian Edition 3.

If languagetool 4.5.1 is activated it will reproducibly crash LO on quit causing document recovery to be run when I next start LO.
Using print-preview only crashes LO when I use it more than once.
This didn’t happen with Version 3.8 which was the one I have used before updating.

Hope this helps.
Cheers
J.T.

Update:

I installed now LibreOffice 6.1.5 from its homepage and tested again LT 4.5.1 with a new LibreOffice profile.

The crash does not appear.

Conclusion:

LT 4.5.1 seems to be incompatible with Debians’ outdated, stable version 5.2.7.2, while LT 3.7 and (reportedly) LT 3.8 still seem to be compatible to Debians’ LibreOffice version.

Could also mean that Debian introduced the fault that LT triggered.

I dont thinks so. Debians LO works fine with older versions of LT.

From this we can conclude that LT changed something which leads to crashes with older LO versions, but works fine with later LO versions.

We only know that LT changed something that caused the Debian release to crash, but we don’t know if the official 5.2.7.2 from which the Debian release was forked has the same issue for LT to trigger.
(not saying that it’s probable, just that it’s possible)

So I upgraded now to Debians coming stable release (codename Buster) which ships LibreOffice 6.1.5.2 and tested it again with LanguageTool-4.5.1.

Result: No crash, works stable.