Back to LanguageTool Homepage - Privacy - Imprint

Libreoffice 4.3.3 Java exceptions


(edgarklus) #1

My configuration:

Opensuse 13.2, OpenJDK 1.8, Libreoffice 4.3.3.2, Languagetool 2.7

The problem:

Since I have updated to Libreoffice 4.3.3.2, Languagetool does not work anymore. Nor can it be de-activated or removed and re-installed. Any attempt to do either triggers the following messages:

  1. javaloader error - could not find class com/sun/star/comp/loader/JavaLoader

and then:

  1. (com.sun.star.uno.RuntimeException) { { Message = "javaloader error - could not find class com/sun/star/comp/loader/JavaLoader", Context = (com.sun.star.uno.XInterface) @0 } }

I have tried OpenJDK 1.7 before, and the result was the same. I have tried a fresh install of Libreoffice, still the same result. What can be wrong here??? I have never had any problems with Languagetool and Libreoffice before.


(Daniel Naber) #2

Please try the Java you can download from http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html. Please make sure it's not only installed, but also activated in LibreOffice (Tools -> Options -> Advanced).


(edgarklus) #3

Thank you for the quick response. I have downloaded, installed and activated the recommended java-version. The result, unfortunately, is still the same. What puzzles me is that other addons to libreoffice which also require java work flawlessly.


(monsieurmona) #4

Hi,

I was struggling with the same issue.

The error message says that it can not find the class JavaLoader at runtime. Which was there during compile time. What I stupidly did is to search for a jar that contains this class and found this.

http://mvnrepository.com/artifact/org.openoffice/ridl/3.2.1

This archive can be easy added to the classpath in LibreOffice. But unfortunately, I received the next error:

(com.sun.star.uno.RuntimeException) { { Message = "javaloader error - no mapping from java to C++ ", Context = (com.sun.star.uno.XInterface) @0 } }

At that point I gave up, removed all LibreOffice related RPMs and installed the ones from the LibreOffice web site. That helped finally.


(artofit) #5

Same issue with Libreoffice 4.3.4 portable