Back to LanguageTool Homepage - Privacy - Imprint

LibreOffice how to install?


(Zoltan T) #1

Hi Guys,
I’ve just installed the LibreOffice Plugin, but I can not figure out how to use it. There is not menu item in the Tools menu. Language Tool is not shown in Tools–> Options --> Language Settings --> Writing aids.
What is strange that the Disable button is greyed out when I select LanguageTool. Not sure if it is enabled.

What should I do? How can I debug the issue?

Oracle JRE1.8 is installed.
I am using LibreOffice 6.0.6.2 on a Xubuntu 18.04.1 LTS machine.
Both Java and LibreOffice are 64bit versions.
I started LibreOffice from the command line hoping I will get some warning messages, but nothing has been shown.


(Daniel Naber) #2

Have you checked https://languagetool.org/issues?


(Zoltan T) #3

Of course. I went through them, but none of the issues were present in my case. (64 bit, java 8, no error message, extension installed etc.)


(Marco A.G.Pinto) #4

The other day I ran LibreOffice 6.0.6.2 in Ubuntu 18.04 and it had no extensions.

You probably need to install a Language Pack with the spellers for your language.


(Zoltan T) #5

Hi Marco,
What do you mean by “it had no extensions”?

The spell checkers are installed (Hunspell SpellChecker). Is there anything else needed? I did not even reach Language Tools Options menu, so I think that it is not installed correctly.


(Marco A.G.Pinto) #6

Hello!

What do you see in: Tools > Extension Manager ?


(Jeremy S.) #7

Start LibreOffice Writter or LibreOffice. Click “Tools” [in english, i use the language german] and next "Extension Manager "

Here see you all extensions, which you have installed.

You can use the LanguageTool “Tools” and next “LanguageTool” or the button “F7” on you keyboard.

Sorry for this bad english, i am speak german.

I hope, i can you help

Your Dallun511


(Zoltan T) #8

Hi,
This is what I see in the Tool menu and in the Extension Manager:

I think it is not installed correctly. The points in the “issues” page did not helped me. I got no warning messages. How could I debug it?


(Zoltan T) #9

I do not have this menu entry :frowning:


(Jeremy S.) #10
  • Deinstall LibreOffice
  • Install new LibreOffice with languagepack (German, English or what do you use)
  • See again in the Extension Manager
  • Are all languagepacks installed?
  • yes, you can install LanguageTool
  • No, you check update for LibreOffice and languagePacks.

Your Dallun511