Back to LanguageTool Homepage - Privacy - Imprint

Local server allow-origin double quotes

Hello LanguageTool team,
today, I spend a few hours to set up the latest local server for LanguageTool on Windows and wanted to give some feedback, since I ran into an error which I suspect many people could have.

If you start the server like this javaw.exe -cp languagetool-server.jar org.languagetool.server.HTTPServer --port 8081 --allow-origin "*" --config config.cfg it works fine. If you start the server like this javaw.exe -cp languagetool-server.jar org.languagetool.server.HTTPServer --port 8081 --allow-origin **'*****'** --config config.cfg it works in Chrome, but not in Firefox.

The double quotes around the * in the allow-origin option are key here. Apparently Chrome handles these differently than Firefox. Maybe you could add a warning somewhere or always replace '’ with "" automatically.

Best regards,
Sebastian