Back to LanguageTool Homepage - Privacy - Imprint

Lokaler LanguageTool-Server auf RaspberryPi

Hallo Forum!

Ich habe (testweise) auf einen RasPi-4 einen lokalen LT-Server installiert. Dieser startet ohne Fehlermeldungen (incl. --public), und es ist auch vom angeschlossenen Rechner unter :8081 ein laufender Dienst zu sehen.

pi@raspi-sf:/opt/LanguageTool-5.5 $ java -cp languagetool-server.jar org.languagetool.server.HTTPServer --port 8081 --allow-origin "*" --public
2021-10-28 19:10:52.520 +0200 INFO  org.languagetool.server.DatabaseAccessOpenSource Not setting up database access, dbDriver is not configured
2021-10-28 17:10:52 +0000 WARNING: running in HTTP mode, consider running LanguageTool behind a reverse proxy that takes care of encryption (HTTPS)
2021-10-28 17:10:52 +0000 WARNING: running in public mode, LanguageTool API can be accessed without restrictions!
2021-10-28 17:10:55 +0000 Setting up thread pool with 10 threads
2021-10-28 17:10:55 +0000 Starting LanguageTool 5.5 (build date: 2021-10-02 12:33:00 +0000, 5e782cc) server on http://localhost:8081...
2021-10-28 17:10:55 +0000 Server started

Wenn ich allerdings versuche, mit LibreOffice, Firefox oder Thunderbird diesen Dienst zu nutzen, funktioniert das nicht. (Ein lokal auf diesem Rechner installierter LT-Server sehr wohl.)

Meine Frage:
Nach entsprechender Suche habe ich in einem bekannten dt. Forum zwei Meinungen dazu gefunden.
Die einen schreiben, dass der LT-Server auf dem RasPi läuft (allerdings recht langsam) und die anderen schreiben, dass der LT-Server generell auf diesem Prozessor oder unter Raspbian nicht läuft (was ich aus den obigen Meldungen allerdings nicht ersehen kann.)

Bevor ich jetzt allzu viel Zeit bei der Fehlersuche verschwende, stellte ich hier die Frage: Läuft ein LT-Server unter diesen Bedingungen oder nicht?

Danke für zielführende Antworten!
Walter

Hallo Walter, funktioniert es denn per curl, sowohl vom RasPi selber als auch von extern?

curl "http://localhost:8081/v2/check?text=Eine+Test&language=de"

Hallo Daniel,
und vielen Dank für deine schnelle Antwort!
Ich lese aus selbiger heraus, dass es wohl generell keine Probleme geben sollte, den Server auf dem Raspi zum Laufen zu bekommen (abgesehen von der erwarteten geringen Performance). Das macht mir Mut!

Jetzt sieht es so aus:

pi@raspi-sf:~ $ curl http://localhost:8081/v2/check?text=Eine+Test&language=de
[1] 25570
pi@raspi-sf:~ $ Error: Missing 'language' parameter, e.g. 'language=en-US' for American English or 'language=fr' for French
[1]+  Fertig                  curl http://localhost:8081/v2/check?text=Eine+Test
pi@raspi-sf:~ $ curl http://localhost:8081/v2/check?text=Eine+Test&language=de-DE
[1] 25642
pi@raspi-sf:~ $ Error: Missing 'language' parameter, e.g. 'language=en-US' for American English or 'language=fr' for French

Ich hoffe, dass ich den erforderlichen Befehl richtig eingegeben habe. Habs auch mit “de” und “de-DE” versucht, wie du ja siehst. Den Server habe ich ganz normal gestartet, und dieser ist auch “zu sehen”.

Walter (bis morgen!)

Es müssen Anführungszeichen um die URL stehen, ohne geht es nicht.

So, auf zur nächsten Runde :wink:

Jetzt sieht es so aus, allerdings kann ich das nicht bewerten:

pi@raspi-sf:/opt/LanguageTool-5.5 $ curl "http://localhost:8081/v2/check?text=Eine+Test&language=de"
{"software":{"name":"LanguageTool","version":"5.5","buildDate":"2021-10-02 12:33:00 +0000","apiVersion":1,"premium":false,"premiumHint":"You might be missing errors on
ly the Premium version can find. Contact us at support<at>languagetoolplus.com.","status":""},"warnings":{"incompleteResults":false},"language":{"name":"German","code"
:"de","detectedLanguage":{"name":"German (Germany)","code":"de-DE","confidence":0.9999912}},"matches":[{"message":"Möglicherweise fehlende grammatische Übereinstimmung
des Genus (männlich, weiblich, sächlich - Beispiel: ‚der Fahrrad‘ statt ‚das Fahrrad‘).","shortMessage":"Evtl. keine Übereinstimmung von Kasus, Genus oder Numerus","r
eplacements":[{"value":"Ein Test"},{"value":"Einem Test"},{"value":"Einen Test"}],"offset":0,"length":9,"context":{"text":"Eine Test","offset":0,"length":9},"sentence"
:"Eine Test","type":{"typeName":"Other"},"rule":{"id":"DE_AGREEMENT","description":"Kongruenz von Nominalphrasen (unvollständig!), z.B. 'mein kleiner(kleines) Haus'","
issueType":"uncategorized","category":{"id":"GRAMMAR","name":"Grammatik"}},"ignoreForIncompleteSentence":true,"contextForSureMatch":8}]}pi@raspi-sf:/opt/LanguageTool-5
.5 $

edit: Im Thunderbird kommt vom LT-Add-on die Meldung, dass … etwas schief gelaufen ist. Das Verbinden mit dem lokalen Server auf dem RasPi wird ohne Fehlermeldung akzeptiert. Ein Test mit einem anderen Port führt wie erwartet zu einer Fehlermeldung.

Der gleiche Befehl auf dem PC eingegeben bringt eine identische Meldung, wie selbiger auf dem RasPi. Und stelle ich das Add-on wieder auf den Server auf dem PC um, funktioniert auch alles wieder.

Das heißt, LT läuft. Es muss also an was anderem liegen, evtl. eine Firewall. Was man noch testen kann ist, ob es von extern zwar mit Firefox nicht geht, dafür aber mit Chrome.

Hi Daniel!

Danke für deine Antwort.
Die Firewall meines Linux-PC ist bewusst für diese Tests komplett deaktiviert. Eine FW ist zwar prinzipiell nicht nötig, da ich außer dem sshd (und den lokalen LT-Server) keinerlei Dienste darauf zu laufen habe und auch keinerlei Ports im Router weitergeleitet/freigegeben sind.
Und der RasPi hat selbst auch keine Firewall. Außerdem kann ich ja mit nmap vom PC aus den lauschenden :8081 auf dem RasPi “sehen”.
Mit Chrome werde ich das mal aus purem Interesse testen - aber in diesem speziellen Fall geht es mir um den Thunderbird.

Bis später … Walter.

Noch eine Antwort am nächsten Morgen:
Mit Chromium (Linux) geht es natürlich auch nicht.
Da haben die User aus dem Forum, welche sagen, dass LT auf dem RasPi nicht läuft, wohl doch Recht. Das ist schade, aber ich “kann damit leben”. Werde also dieses “Projekt” erst mal auf die bewusste “lange Bank” schieben.
Danke für deine freundliche Unterstützung!

Walter