Back to LanguageTool Homepage - Privacy - Imprint

LT and OpenOffice problem


#1

Hello,

I am having problems using LT (ver. 3.7) with OpenOffice (ver 4.1)
on Mac OS X 10.9.5. The input is the txt file with contents:
Jack went up up the hill. However Jane went down.
I choose LT to check the document. A pop-up window with "LT" appears
and catches the first error "up up". I click "Ignore once". Then
a small pop-up window (with no "LT") appears with the message
"Spelling check is complete". Thus the check skips the LT suggested
change to "However,", and may go to only spell-check.
I have searched the LT forum, but could not find a relevant article.

Any suggestions?

Thanks,
JohnM


(Daniel Naber) #2

I don't have OpenOffice installed, but I cannot reproduce this with LibreOffice 5.1. It might be a bug in OpenOffice. Are you sure you don't have disabled some rules?


#3

I have installed both OpenOffice 4.1.3, LibreOffice 5.3.2.2
and LT 3.7 on both. The behavior is the same.
The basic problem seems to be that when I try to
do a LT grammer check by choosing
Tools/LanguageTool/Check Text
OO and LO both start their OO or LO grammar check pop-up
rather than the LT pop-up.

I tried reinstalling LanguageTool-3.7.oxt, reinstalling Java, and
the (often) sovereign cure of a reboot. These did not fix the
problem. Probably I should delete then reinstall everything
related to OpenOffice or LibreOffice.

Meanwhile, I have switched to using the browser/html version of LT. This
work well, although a pdf version would be even better since
my final output is in pdf.


(Daniel Naber) #4

Have you checked https://languagetool.org/issues/? It says:

LibreOffice comes with its own integrated grammar checker (LightProof) which disables LanguageTool for English and Russian. Use Options -> Language Settings -> Writing aids -> Edit... to disable LightProof and enable LanguageTool for the language you are working with to make LanguageTool work.