Back to LanguageTool Homepage - Privacy - Imprint

LT integration on my web-page is broken

I have been running LT on my personal web-page for a while to test new rules for Ukrainian.
The page has local LT running only with Ukrainian module (and limited set of jars).
Recently with 5.7-SNAPSHOT it stopped checking pages (returning no errors).
The log has this message:
org.languagetool.language.LanguageIdentifier Cannot consider noopLanguages because not in fastText mode: [ru, uk, be]

Would anybody know why this may happen?

The quick fix is to set fasttextModel and fasttextBinary in the server’s configuration (--config ...). If you don’t want to do that: How exactly do you send the requests? You could remove the noopLanguages parameter and it should work.

My requests has only disabledRules, allowIncompleteResults=true, text, and language=uk paramerers
What do I set fasttextModel property to? It looks like it requires a proper model

You can use lid.176.bin from Language identification · fastText

Ahh, it looks like the problem was with the editor_plugin2.js - it relies on (very old) jquery 1.7 and the page had newer jquery (3) from the CMS.
So the message about noop was irrelevant.
Sorry for the false alarm!

P.S. I wonder if it’s time to update the integration page with newer jquery