New LibreOffice 7.4 LanguageTool Remote Grammar Checker

New LibreOffice 7.4 LanguageTool Remote Grammar Checker

How to configure this functionality?
With which LT server can this be used?
LT server settings

1 Like

If you use the free version, please set https://api.languagetool.org/v2 as the base URL and leave “Username” And “API key” empty.

If you’re a premium user, use https://api.languagetoolplus.com/v2 as the base URL and set your email as the username and the API key from here).

With a local server, use http://localhost:8081/v2.

You might also need to activate other settings. Here’s a summary of those three settings:

You might need to close and re-open the Options dialog to make sure the next setting becomes available:

lt-step3

1 Like

Thanks!

This can be used with a local server, right?

Yes. Use http://localhost:8081/v2 as the base URL in that case, leaving username and API key empty.

It works wonder indeed :slight_smile:

My server works:

– and preferences are as they should be in LibreOffice:

– however unless I’m missing something, there’s no checking of grammar:

Should I raise an issue in GitHub?

% pkg info -x libreoffice
libreoffice-7.4.1.2
% freebsd-version -kru ; uname -aKU
14.0-CURRENT
14.0-CURRENT
14.0-CURRENT
FreeBSD mowa219-gjp4-8570p-freebsd 14.0-CURRENT FreeBSD 14.0-CURRENT #23 main-n258470-661faa1f77c0: Thu Oct  6 21:47:17 BST 2022     grahamperrin@mowa219-gjp4-8570p-freebsd:/usr/obj/usr/src/amd64.amd64/sys/GENERIC-NODEBUG amd64 1400072 1400072
% 

I chose to install the a;extension, which warns users to not have this:

/v2

– or this:

/

– at the tail of the URL.

image

Experimentally: I disabled the extension, set this as the URL in LibreOffice preferences for LanguageTool:

http://localhost:8081

– then quit and reopened the application. No improvement, as far as I can tell, so I reverted to what’s specified in this topic:

http://localhost:8081/v2

You’re using the add-on. This forum post describes how to use LT with the LibreOffice (7.4 or later) integration, not with the add-on.

Hi,
After installing the latest version of LO and following the instruction in this post and here, spelling and grammar mistakes are not underlined. I tried restarting in safe mode and repeating the steps, but the problem persists with all languages except German. Any ideas why this is happening (I am using an ARM processor)? I am attaching my test file.
Test-Languagetool-multiple-l.odt (58.1 KB)

By the way, the instructions here may be more helpful if one was told to press the ok button between point 3 and 4 and then reopen the settings, otherwise the " LanguageTool Remote Grammar Checker" does not appear among the available language modules. Does anybody know where to post this to let the person know? Thanks!

Version: 7.4.2.3 / LibreOffice Community
Build ID: 382eef1f22670f7f4118c8c2dd222ec7ad009daf
CPU threads: 8; OS: Mac OS X 12.6; UI render: default; VCL: osx
Locale: it-IT (it_IT.UTF-8); UI: en-US
Calc: threaded

Hello there, thank you for sharing this with us. I changed the instructions and added the sub-step.
For your other problem, I don’t see why it’s not working in your case. Please refer to our customer support or let’s hope if anybody else has the same issue and can present a solution to you.

Don’t mention it, kudos for the improvement of the instructions.
I am updating my post since I have improved the situation a little, but I am definitely writing to the customer service.

Meanwhile, here are some suggestions (should I post them somewhere else?).

Would it be possible to integrate some screenshots for Mac (preferences are in a different place from Windows and Linux)?

A propos, I would have a suggestion on the way Languagetool is integrated to Libreoffice, please tell me if this is not the place.
When I initially install Libreoffice, I understand that Languagetool is not the default spelling and grammar checker since not everybody has an internet connection.

However.

  1. there should be an easy way for users to discover that a grammar check is possible.
  2. for example under tools/language/ there could be a grammar section leading to the preferences (this would be easy enough for the average user
  3. then, once the user is taken to LanguageTool Server Settings in the preferences it would be helpful to be able to access the instructions directly from there (otherwise, he would have to begin searching the internet for the right page, again not a piece of cake for the average user).
  4. the easiest way would be to point to the instructions page (but one would have now two windows to deal with (not something everybody handles easily)
  5. better still, one should be taken to the LanguageTool Server Settings directly
    5.1 LanguageTool Server Settings is really obscure fro one who does not know what LanguageTool is: something hinting to grammar/spelling check would be better
  6. Here Enabling LanguageTool could be renamed LanguageTool (language checker) or somthing alike and one could have LanguageTool linking to LanguageTool.org
  7. Once the checkbox has been checked, one should see not three but four slots each with a checkbox next to it:
    7.1 one named LanguageTool Free base url prefilled with the right url
    7.2 one named LanguageTool Premium base url prefilled with the right url
    7.3 the slot for the username turning from grey to white when the premium account url has been checked
    7.4 the API key slot.

The reasoning behind all this is that the average user who does not have a clue about LanguageTool will discover it and install it effortlessly. The experienced user will have no problem whatsoever.

This is just a suggestion, if anybody comes up with a better way of doing this, all the better!