Back to LanguageTool Homepage - Privacy - Imprint

[Resolved] I don't find the rules in my computer


(Papy Octet) #1

Hello,
I'v just installed LT 1.9 on my LibreOffice 3.5.4 on Ubuntu 12.04 64 bits.
I would like to know where I can find the rules.

I made a search via Nautilus ( grammar.xml ) but unsuccessfully.

Thank you for your help.


(Daniel Naber) #2

On So 30.09.2012, 09:28:52 you wrote:

I'v just installed LT 1.9 on my LibreOffice 3.5.4 on Ubuntu 12.04 64
bits. I would like to know where I can find the rules.

For me, the English file is at
~/config/libreoffice/3/user/extensions/tmp/extensions/lu70aa76.tmp_/LanguageTool-1.8.oxt/rules/en/grammar.xml

"lu70aa76.tmp_" looks like a random number and might be different on your
system.

Regards
Daniel

--
http://www.danielnaber.de


(Papy Octet) #3

Hello dnaber,
Thank you for your answer.

A friend of mine has desabled a rule when using LT 1.9 and we will re-activate that rule. But we don't know how to do. So I will try tou have a look at the rules in the original state and after I disable one of the rules. It seems there is an option int the scrit of the rule whitch is set on with a specific value.

Maybe another way to re-activate a desabled rule exists but I don't find it on this web site.

Thank you for your help.

Sorry for my bad english. I do my best in my explanations.

I find it finally at :
~/config/libreoffice/3/user/extensions/tmp/extensions/luqbx2vh.tmp_/LanguageTool-stable.oxt/org/LanguageTools/rules/fr
The file grammar.xml is there.

Not very easy to find it at all :-0

So I have now to find the rules editor. The tutorial in LT web site gives no explanations enough to find and use it.

I find that too

It is just an .xml file and I can edit it easily with a simple text editor like Gedit, for example.

Thank you for your help.

EN FRANÇAIS : j'ai déposé une réponse en français à cette adresse : http://fr.libreofficeforum.org/node/4444#comment-20228.


(Daniel Naber) #4

On So 30.09.2012, 19:45:55 you wrote:

A friend of mine has desabled a rule when using LT 1.9 and we will
re-activate that rule.

If you disable a rule via configuration dialog, its ID will be stored here:
~/.languagetool.cfg
You can remove it from there (while LanguageTool is not running)

Regards
Daniel

--
http://www.danielnaber.de


(Papy Octet) #5

Thank you dnaber.
It all fine.