Back to LanguageTool Homepage - Privacy - Imprint

Sending text using only url


(Ruud Baars) #1

There is a lot of talk about language errors on social media. It would be great to show LT is catching those, by showing it using only an url, like:
https://www.languagetool.org/nl?txt=Dit%20is%20vout or something like that.


(Michael) #2

Great idea!


(Jan Schreiber) #3

I agree. Could be useful for many things.


(Daniel Naber) #4

I like that idea, too. The part that’s easy to implement is showing the text from the URL. But how to create that URL? Have a new page where users can enter text and redirect them to the result page? Is the result page read only or editable? Or use a completely different approach?


(Ruud Baars) #5

I think just jump to the languagetool.org in the right language with the test in it, and check executed would be great.
For me, I would do that manually at first, just quoting the text and adding; it might even have to be passed through a link shortener.
It would even be possible to check new tweets and have them checked automatically, sending a reply like ‘there might be a mistake in your tweet, please check here:’


(Daniel Naber) #6

I have added this now, e.g.:

https://languagetool.org/?text=This%20is%20an%20test

This always works with automatic language detection, so it can also be used to show issues with that. Whether you use the homepage or a sub page (like /nl/) doesn’t make a difference.


(Daniel Naber) #7

For now, this is limited to 200 characters.


(Ruud Baars) #8

Super.


(Ruud Baars) #9

Sorry, this was not the case. There was a trailing space in spelling.txt, which caused a runtime error.

But also this makes LT crash: http://localhost:8081/v2/check?language=nl&text=Datum+en+Plaats%3A+Zater­dag+30+augustus+2014


(Daniel Naber) #10

There’s now a page that helps to create these links: https://languagetool.org/link - it still has a bug, you need to click the link twice two work (I mean the link on that page, for the user who gets the link it will work like any other link).


(Ruud Baars) #11

First time around, there was no line around the text box, and it did not work; after a refresh, it did. Not serious, but just so you know. Nice help!


(Daniel Naber) #12

This will be fixed with the next update. It’s better to submit these cases as issues on github, here they get easily lost (as you edited your post, I didn’t get any notification about that edit and almost overlooked it).


(Maciej Pędzich) #14

You can count on my help, if you need it :wink: