Back to LanguageTool Homepage - Privacy - Imprint

Test the new LanguageTool add-on for Google Docs

(Giang Lê Hoàng) #26

Can I use my stand-alone version of Language Tool’s server? I want to add some more syntax on my own.

(jaumeortola) #27

You can change the LT server in the options and use your own server. But it has to be an online server, not a local server, because a local server cannot be accessed from the Google servers where the add-on is executed.

To enable using a local LT server, the add-on should be re-written and some server-side code moved to client side.

(Giang Lê Hoàng) #28

To enable using a local LT server, the add-on should be re-written and some server-side code moved to client side.

Can you modify this extension for local server accessible (I don’t know how to set up an online server…).

Thank you!

(jaumeortola) #29

It would be some work, and I am not sure if it will be viable or if there will be some downside. There is no plan to do it at the moment.

(Giang Lê Hoàng) #30

Yeah, thank you!


Addon is broken:
ScriptError: Acció no permesa

(Daniel Naber) #32

I’m sorry, I cannot reproduce this. On installation, did you get a window like this and did you click “Allow”?


Right! I’ve tested with another account and It works. Why doesn’t it work with my other account?
I’ve tested both accounts and it’s really strange that it works well with one and not another.

I clicked Allow in both accounts. I even tried to un-install and re-install clicking again Allow in the account that does not work.

(Daniel Naber) #34

Have you tested it with the same document? Did you have write access to the document in both cases?


Yes, the same doc, write and proprietary access.

(Ruud Baars) #36

You could do that, if your local machine is a server, and you can allow outside traffic on it…

(Daniel Naber) #37

Do you have other add-on running that might interfere? If not, I’m running out of ideas what the issue might be.


Wait a second, do you mean “open write access”? I’ve tried opening the doc with an access link for write access and now it works

Is this necessary?

(Daniel Naber) #39

It seems so. I just tested this, but I don’t even get the “Add-ons” menu when I don’t have write access, so I don’t get an error either.


Ok, thank you. It seems that the LanguageTool must access the doc text from the outside. I thought that the permissions given during the installation process were to avoid this “write access” thing :stuck_out_tongue:

(Muireann Ní Sídach) #41

Thank you, it’s just amazing.



is it possible to run this add-on against a local instance of LanguageTool (https://localhost:8081/api/v2/) or does this add-on only work against public web facing URL ( https://{some non local IP or domain-name}/api/v2/ ) ?

Though I would understand if not:

  • usually local instance is for privacy-minded people who don’t very much like their data going through a 3rd party
  • Google Docs is the absolute opposite of privacy (all your data lives on someone else’s computer).

But at least if one already has a local servlet running for other actual privacy reasons, one might as well use it for google docs too. (Which has the bonus advantage of not taxing languagetool’s public servers and reducing your operating costs).

(Daniel Naber) #43

Using your own server should be possible. This is from the settings dialog:



Sorry, I didn’t express myself clearly enough. The question was not where the option for the URL is (I found it), but whether a http:// on local host could work in this place. I have no clear idea of the architecture of Google Docs (I seldom use it)

  • The add-on code running in the browser locally, I think ? (Not some server-side stuff at Google’s, that would never be able to connect locally)
  • Are there any restriction against cross-site scripting, etc. That would prevent an http:// server being used by google docs running on https:// ?
  • Are there any restriction against cross-site scripting, etc. That would a web app served from the internet to contact a localhost address ?

I’ve tried switching the URL, but the corrections from LanguageTool seem to not be working, I’m getting: “Error: Cannot connect to the server http://localhost:8081/v2” message in the check window.
(Meanwhile, the same URL works perfectly with the LanguageTool Firefox plugin).

I was wondering if the problem is on my side (I’m doing something wrong), or if there are technical limitations (due to anti-XSS, etc.)

(Daniel Naber) #45

You’re right, that part of the code could be server-side (haven’t checked now). If you have started the server with --allow-origin '*' and it still doesn’t work, it’s probably not possible.