Back to LanguageTool Homepage - Privacy - Imprint

5.6 plugin for LibreOffice wildly unstable

I’ve found the 5.6 plugin for LibreOffice wildly unstable since its release:

  • Frequent freezing–eventually every several seconds, often causing Libreoffice to lockup, requiring restarting LO.
  • Incorrectly identifying the first three words of a paragraph as a sentence–then telling me is too simple of a sentence…when it’s not a sentence at all, just the first three words of a longer sentence.
  • GUI errors such as ampersands at the beginning of button labels, and pop-up help boxes with no padding.

I’m no newbie, I’m running OpenSUSE Tumbleweed with a KDE desktop. My typical documents are several pages in length, most with minimal graphics. Disabling LanguageTool solves the instability, so it’s definitely related to the plugin. Is this on more than SUSE? Anyone else seeing this?

Thanks,
Lance

1 Like

I encounter the same problems, but predominantly crashes. My post is here: LanguageTool 5.6 causes LibreOffice Writer to crash

What OS are you using?

Thanks for your reply. I use Ubuntu 21.10. Please see these posts for details on the crashes in the link that I posted in my first comment.