Back to LanguageTool Homepage - Privacy - Imprint

5.8-SNAPSHOT oxt extension is failing to check

I’ve just built oxt from the latest git, and it installed fine. But when I try to run LT on my Ukrainian document in LibreOffice Writer with “Check Text” or any other option I am getting this error:
It seems the automatic grammar check is disabled. Please enable “Check grammar as you type” at “Tools”/“Options”/“Language Settings”/“Writing Aids”
But when go to Writing Ads, this open is enabled. I’ve tried to uncheck/check it and it didn’t help.
It’s LibreOffice 7.2.7.2, Linux (Fedora 35), OpenJDK 11.0.15

Did you also enable “Check spelling as you type”?

If I do “Check spelling as you type” then spell-checking kicks in, but I want grammar checking from LT.
BTW I was able to reproduce it with 5.8 oxt (and I removed SNAPSHOT oxt and cached extension directory in LO config folder before installing).

You have to enable both:

  • Check spelling as you type
  • Check grammar as you type

After that, test some grammar errors. For example, if you put in more than one blank between two words, it should be underlined by a green wave.
By the way, what language you use as default?

Oh, thank you, that worked. I guess I didn’t expect spelling option to affect grammar (particularly I didn’t want spellchecking dictionary to cover/mess with grammar errors).