Back to LanguageTool Homepage - Privacy - Imprint

ANN: LanguageTool 5.1

I’m pleased to announce the release of LanguageTool 5.1. As usual, it is available at languagetool.org. Changes include:

  • Error detection updates for Catalan, Dutch, English, French, German, Italian, Portuguese, Russian, Spanish, and Ukrainian
  • Internal bug fixes and updates

A more detailed list of changes is available in the change log.

The update from within LibreOffice (Tools → Extension Manager) is also possible.

SHA256 check sums:

52b134f6f0a5283162ed1f4086988a65c29b70dd806a645cd1afa01baaa39fd3  LanguageTool-5.1.oxt
c91ff43d54c863a9389a81c5fa1a6723041b982435f220e9c2c4db843b66d1b6  LanguageTool-5.1.zip

Congratulations on the new release. Unfortunately, I get the following error when I attempt to use it.

image

Version: 6.4.6.2 (x64)
Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU threads: 12; OS: Windows 10.0 Build 19041; UI render: GL; VCL: win;
Locale: en-AU (en_AU); UI-Language: en-GB
Calc: CL

Changing the locale settings for the document had no effect. Let me know if you require any further information.

@Fred.Kruse Any idea?

Managed to get it working. Reinstalled the previous version and attempted the upgrade again. Worked this time.

The error can occur, if you try to start the spell and grammar check dialog before LO has called the interface to check the first sentence. I added a bug fix for this in my last update today

The same error occurs on ubuntu 18.04lts along with Libreoffice Writer -7.x -, when I use the F7 function key. It works not too well using the Spell Check option.
Version: 7.1.0.0.alpha0+
Build ID: a8c218a52a639b0e7f689dea878a0421702628e0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: it-IT (it_IT.UTF-8); UI: it-IT
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-09-25_22:25:07
Calc: threaded

Should we expect the release of version 5.1.1?

@Fred.Kruse can you point me to the commit id? I can make a 5.1.1 release then (or do you think the problem is extremely rare?)

I don’t know if the problem is rare or not. It occurs if someone is very fast and starts the dialog before any iteration in the background was done.
A new release at this point is not a good idea I think. There was some other changes and I’m working on some bug fixes right now. Could we shift it a few days?

By release, I mean a release based on 5.0 with only the bug fixes ported back to 5.0.

I mean 5.1, of course…

Yes, this is a good idea. But the change is hidden in a huge commit. Is it possible to get back to the code of 5.1. Only three lines are the solution to solves the bug:

        if(docLanguage == null) {
          docLanguage = getLanguage();
        }

placed after:

        if (ltDialog != null) {
          ltDialog.closeDialog();
        }

in file MultiDocumentsHandler.java.

It is placed in commit https://github.com/languagetool-org/languagetool/commit/db6ba4a4e0d0d403d36f9c040de506b02441f271

There’s now version 5.1.1, could you confirm it’s okay? https://languagetool.org/download/LanguageTool-5.1.1.oxt - it’s not linked yet, I’d link it once someone else has tested it

There was no feedback, but as the fix should be okay, I’ve now released and linked 5.1.1 (https://languagetool.org/download/LanguageTool-5.1.1.oxt).

5.1.2 has been released with a few fixes (see changes): https://languagetool.org/download/LanguageTool-5.1.2.oxt

sha256 checksum:
262f144df5b91b96a57a7e93294d7acbc46f39e2b326995098193b30c2091960 LanguageTool-5.1.2.oxt

5.1.3 has just been released with a fix for https://github.com/languagetool-org/languagetool/issues/3666. Only the LibreOffice/OpenOffice add-on is affected.

sha256 checksum:
3c3288a4a651553b3f9e762a027fab75a38b35050f522cbf8fce2554977dc7f0 LanguageTool-5.1.3.oxt