Back to LanguageTool Homepage - Privacy - Imprint

Announcement: LanguageTool 3.8


(Daniel Naber) #1

LanguageTool 3.8 has been released and is available from the homepage. Changes include:

  • Error detection rule updates for Catalan, Dutch, English, German, Polish, Portuguese, Russian, Slovak, and Ukrainian
  • Some internal Java API and HTTP API cleanups

A detailed list of changes is available in the change log.

SHA256 check sums:

  • d021d175a51aa3cdca175b859dfe0d2db1dfe0cd76761a9309cd0dfb5178c0e8 LanguageTool-3.8.oxt
  • d9127a26d05c12c7198fa2d23607cea19f330d24609aab4f9b13c47f15600ae2 LanguageTool-3.8.oxt (updated 2017-06-28)
  • e910a4ea0f0000409ba91220cbf56ae0f23c814efab5d2845f8059cbb918453c LanguageTool-3.8.zip

(Lodewijk Arie van Brienen) #2

open office reports "no data stream"
I fear that the .oxt is broken.


(Daniel Naber) #3

It works for me with LibreOffice (5.1.6.2). How exactly did you try to install it? Which version of OO are you using?


(Lodewijk Arie van Brienen) #4

OO 4.1.3 (latest)
downloaded from the homepage.

I've tried to do a clean install, the only result of that was needing to download 3.7 all over again.

did you check with the copy supplied by the homepage, or did you simply test with the one you compiled? the former could have suffered from an upload-error and thus require a re-upload.


(Daniel Naber) #5

I've tested with the version from the homepage. With OO, I can reproduce the issue. But after the error ("Got no data stream"), it first works anyway. Then after the next new start, OO crashes. With LT 3.7, there's no error message but also a crash after the next start of OO. This is going to be difficult to debug I guess...


(Lodewijk Arie van Brienen) #6

I've done a clean reinstall of 3.7, and have restarted two times without any crashes since.

Perhaps LO is more lenient with checksum issues.


(Daniel Naber) #7

Could you try if http://danielnaber.de/tmp/LanguageTool-3.9-SNAPSHOT.oxt works for you? I think I've found and fixed the issue.


(Lodewijk Arie van Brienen) #8

Yes, it works.


(Daniel Naber) #9

By "Yes" you mean you have tried the new version and it fixes the issue?


(Daniel Naber) #10

FYI, As the fix was not a code change but only a change in the way the ZIP (or *.oxt) was created, I've simply replaced the file with a new version, without increasing the version number.


(Tiago F. Santos) #11

Considering OpenOffice is "on life support" and almost discontinued, should it still be supported by LanguageTool?
For more conservative purposes, is there any reason to not upgrade to LibreOffice Still branch?


(Daniel Naber) #12

That's a valid question... my suggestion would be to remove the term "OpenOffice" from the languagetool.org homepage and see if people actually ask for OpenOffice support.


(Daniel Naber) #13

As there were no objections, I've done that now (more or less) for the languages I work with (English and German).