Back to LanguageTool Homepage - Privacy - Imprint

Autodetect of the Russian, German, Polish and more..more language does not work

Autodetect of the Russian language does not work.

Proof:

Could you send that text as plain text (not as a screenshot), so we can reproduce the issue?

I don’t remember the text. But this problem occurs in any Russian text.

The problem has been around for a very long time, or since LT use. Tested on 4 computers in the company.

Well, it’s in the screenshot :slight_smile:

But this problem occurs in any Russian text.

I cannot reproduce it with Russian text copied from languagetool.org. Could you use the “Send feedback” link in the browser add-on to contact us when this happens again? This way we’ll get information about your browser that will help us debug the issue.

The problem occurs when the text is placed on the exact domain and page
translate.google.pl <===!!!
Extremely easy to reproduce, so what’s the problem.

Трахни тебя.

You will need to tell your browser that you speak Russian, LanguageTool will then consider it also for short texts. Use these dialogs:

Firefox:

Chrome:

Does not work on most languages, automatically sets to British English all the time!
Which is bad, very bad!
Test OS Windows 7 Polish

So are you saying that detection doesn’t work even when you have added Russian as a language to the browser settings? I also don’t see your feedback via the “Feedback” link in the add-on yet.

It doesn’t matter if it’s Russian, German or hundreds of other languages. Always detected as English-British. So total wrong!

I’m sorry, I can’t really help you if you’re not answering my questions or trying the workarounds I suggest. If you have further feedback, please use the “Feedback” link in the add-on.