Back to LanguageTool Homepage - Privacy - Imprint

Avoid spell check on certain HTML inputs manually

Sometimes I would like to avoid LanguageTool to work on certain inputs. Is there a way to flag html inputs with an attribute so language tool ignores them?

Usually, spellcheck="false" should do just that.

You’re right. Strange, though, I had an instance where LT was active while spellcheck was set to false. Might have been a typo, I’ll keep an eye on it and report back.

It looks like spellcheck=false does not disable LT on this page: https://r2u.org.ua/check
There’s inner frame for TinyMCE with spellcheck=“false” on body but LT gets activated there.

We force support for TinyMCE inputs. Probably it’s worth adding a custom attribute like ‘data-lt=“false”’. I will take care.

Thanks, I’ll add ‘data-lt=“false”’ to my page then.

Please note: It will take ~2 weeks until we have rolled out the update

Sure, I understand, thanks

Hi @arysin,

quick update: It’s rolled out. Elements with data-lt=false are now ignored. However we will introduce a change to this: We will rename the attribute from “data-lt” to “data-lt-active”. So if you want to disable LanguageTool, you should set both attributes for now and in the future you will only need “data-lt-active=false”.

I’m sorry if this causes any inconvenience.

Kind regards,
Chris

Many thanks!

Any ETA of this renaming?

Hi, sorry it takes us a bit longer. We don’t have an exact date but expect it at the beginning of October.
Until then: Set both attributes and you’re safe.

Hello! Any new ETA of the renaming?

data-lt-active is the current name of the attribute. The recently published LT add-on version will work with that.

Yes. data-lt-active is now rolled out to all users.

I see LT addon (Firefox) still activated on https://r2u.org.ua/check
And I have data-lt-active="false" on the textarea

The “data-lt-active” isn’t set on the element where the user types in. The textarea is invisible in the background. The user types within a TinyMCE iframe.

Sorry, I could not find an easy way how to add that flag on the iframe. Can we please update http://wiki.languagetool.org/integration-on-websites with some hints on how to set that flag on the web-page?

@tiff Hi Christopher, I’ve put “data-lt-active=false” in 4 places in my page (https://r2u.org.ua/check) but Firefox and Chrome plugins are still checking it. Can you please give me a hint on what I am doing wrong?

I can only guess what the problem is: Maybe the attribute is set after the LanguageTool add-on has initialized itself?