Back to LanguageTool Homepage - Privacy - Imprint

Can't enable a rule that's off by default


(Andriy) #1

I have an experimental rule in Ukrainian (UK_ADJ_NOUN_INFLECTION_AGREEMENT) that I used to be able to turn on via API (by adding &enabledRules:"UK_ADJ_NOUN_INFLECTION_AGREEMENT"). This does not seem to work any more.
I also tried -e UK_ADJ_NOUN_INFLECTION_AGREEMENT for commandline tools and it didn't work either.
I wonder if it's related to https://github.com/languagetool-org/languagetool/commit/f08b52c0152241aa5178e8249149a26a16b625ac#diff-9831aa21e657b6590b2277e63963ed03?

Does this option work for anybody?

Thanks
Andriy


(Tiago F. Santos) #2

Tested it now with the latest build and I can confirm.
In the LibreOffice plugin it works as expected but on LT standalone application, all rules appear as active.

PS - The only rule I notice disabled is a Java rule for long sentences. Not sure if it is old settings related. I know that in LO the settings are not purged between reinstalls.


(Andriy) #3

This seems to be working for me now with latest code (I can enable a rule via REST API), not sure if somethings has been changed or I was doing something wrong before.