Back to LanguageTool Homepage - Privacy - Imprint

Can't find LanguageTool settings in LibreOffice


#1

The stand-alone LanguageTool GUI provides various settings, such as

  • rules to apply,
  • mother tongue for false friends detection or
  • path to n-gram data.

In LibreOffice I cannot find any way to access these settings. Neither via Extras -> Options, nor via Extras -> Extension Manager. Clicking on the LanguageTool extension in the extension manager, the Options button remains greyed out.

How can LanguageTool be configured in LibreOffice?


(Lodewijk Arie van Brienen) #2

In OpenOffice it's in the spellchecker menu. Try there.


#3

Any hint where to look for a spellchecker menu? Neither the interactive spellchecker nor menu Extras -> Options -> Language settings seems to provide a way to access LanguageTool settings.


(Lodewijk Arie van Brienen) #4

In OpenOffice the spellchecker uses the first portion of the Extras menu for itself and LangaugeTool places itself as a sub-menu within that portion. I was guessing it would be the same with LibreOffice.


(Daniel Naber) #5

The options of LT can be found here (LibreOffice 5.0):


#6

Thank you both! I can see it now.

However, I'd swear the whole LanguageTool menu wasn't there before. Unfortunately, I cannot reproduce that again. I've just had a blue screen which reset several LibreOffice settings. And now it's there. I'll report back if I ever manage to reproduce this again.


(Lodewijk Arie van Brienen) #7

OpenOffice allows you to customize the menus. Maybe someone had done the same with your copy of LibreOffice?


#8

This is quite a fresh LibreOffice installation that I manage myself. So I have no idea what could have been wrong. Trying to reproduce the issue would mean to deinstall LibreOffice, remove all LibreOffice profile data and reinstall LibreOffice again. I can do that, but not within the next days. FTR, this is LibreOffice 5.3.0.3 (x64) with LanguageTool 3.6 on Windows 7 (x64).