Back to LanguageTool Homepage - Privacy - Imprint

Can't get server response


(alex) #1

I set a new instance of LTTool server local. I can visit localhost:8081/?language=en&text=my+text and get XML response correctly. But while I deploy the website of LT. The Index warning me that

"Error: Did not get XML response from service. Please try again in one minute."

I've already modified the proxy.php:
curl_setopt($curl, CURLOPT_URL, "https://localhost");
curl_setopt($curl, CURLOPT_PORT, 8081);

as well as include/header.php:
languagetool_rpc_url : "http://localhost/online-check/tiny_mce/plugins/atd-tinymce/server/proxy.php",

By the way, the default request URL is :https://languagetool.org

I got this: Error: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
Then I try to set curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false); to ignore SSL verify, but it doesn't work.

Does anyone help?
Beat Regards,


(Daniel Naber) #2

Have you tried using just HTTP instead of HTTPS? As long as the server process is running on localhost it shouldn't be less secure.


(alex) #3

Thanks dnaber, I change to http as you said. The website still warning "Error: Did not get XML response from service. Please try again in one minute."

But the server in CMD dialog echo : Check done: 272 chars, en-US, http://localhost/, handlers:1, queue:0,7 matches, 1648ms, agent:-, sent. It suppose means the server receive the request. But the website client still warming error Did not get XML response from service.

At last, after send request : http://localhost:8081/?language=en&text=my+text. The server console echo An error has occurred. Stacktrace follows: java.lang.ILLegalArgumentsException: Missing "text" parameter at org.languagetool.server.LanguageToolHttpHandler.handle(LanguageToolHttpHandler.java:202).
I wonder how to fix it.


(Daniel Naber) #4

It seems the proxy doesn't work. Can you try debugging with curl as documented on http://wiki.languagetool.org/integration-on-websites?

You can ignore that on the first request.


(alex) #5

To test proxy.php,
curl --data "language=en-US&text=My+texd" http://localhost/online-check/tiny_mce/plugins/atd-tinymce/server/proxy.php
echo: Error: couldn't connect to host.

But I can visit the proxy.php, it shows Error: this proxy only supports POST requests

my PHP Version 5.2.6. and my proxy.php is this one you mentioned in other topics.
https://raw.githubusercontent.com/languagetool-org/languagetool-website/f8d2a4567b6af43db287967534b0c10f2e26c828/www/online-check/tiny_mce/plugins/atd-tinymce/server/proxy.php


(Daniel Naber) #6

So you can access http://localhost/online-check/tiny_mce/plugins/atd-tinymce/server/proxy.php with a browser but not with curl? That's strange, maybe try http://127.0.0.1/online-check/tiny_mce/plugins/atd-tinymce/server/proxy.php instead. You could also look for your web server logfile, it should contain the PHP errors, if any.


(alex) #7

It works somehow, I didn't modified the proxy.php nor languagetool_rpc_url neither. Just that good!
I'm really appreciate for your help, dnaber.

Best wish,