Back to LanguageTool Homepage - Privacy - Imprint

Change default language

Hey,

I am using LT on Discord while I type in Dutch. I know that this tool detects language which should be checked but is there a way to force it manually? I would like on site XXX only Dutch to be checked. At another website another language.

Now LT tells you have errors while it is not true because it checks different language than is being typed.

Language detection should work fine, as long as you have typed more than maybe 15-20 characters. If it doesn’t, maybe that’s because you type in languages you don’t have your browser configured for. Here are the dialogs in the browser settings where you can set those languages:

Firefox:

Chrome:

Thanks, but it doesn’t solve the problem. If I write constantly in the same window (tab), and same field a Dutch text it is being detected as different one - English or Polish (those I have in Firefox). Sometimes it takes one long sentence to LT detect correct language.
Generally it works really bad, so personal setting for the language should be added, then you can enforce that HERE (in this field, tab) is only language X or X and Y.

Could you post an example of a sentence where detection doesn’t work via the “send feedback” link in the add-on?

It has been send to the feedback email address. ^^

Thanks, but could you send it via the “send feedback” link in the add-on? That will add some information about your browser setup for debugging:

toolbar-popup-en-feedback

Done :slight_smile:

The problem is that your browser still isn’t configured to accept Dutch. It has pl (Polish), en-US and en, but not nl (Dutch).

Hmm i checked it again and that was true. Gonna restart FF and check again