Chrome extension changes language arbitrarily

Hello everyone.
The extension for Chrome (used with Brave) changes the language arbitrarily.
I was writing an article on my website which is in French language (from France).
So I write :
Fabulation !
LanguageTool shows me an error:

Possible typo
Do not use a space before the final punctuation mark.

However, in the French language, wherever it comes from, you always put a space before an exclamation mark, a question mark, or a first, second or third closed quotation mark.
When I write in one language, it is extremely annoying to be bothered by the rules of other languages.

The icing on the cake is that since LanguageTool uses another language, the synonym suggestions (which I often use to vary my writing) are unusable since they are for another language.
Nevertheless, I don’t regret my subscription to LanguageTool Premium which is much more efficient than Druide Antidote (which no longer offers native versions for GNU/Linux). My texts are now much better.

Does anyone know a way to get rid of this inconvenience?
Thank you in advance.

1 Like

Could you please provide the full text you have written? (Or at least enough of it to reproduce the problem.)

Hello, denaber.
Here is the text:

Thank you for your attention.Jeudi 23 mars, on bloque tout !

Ce jeudi 23 mars 2023, on bloque tout par la grève générale.
Jamais des moutons, jamais soumis à un banquier président !

Aujourd’hui, Emmanuel Macron a menti aux Français.
Vous ne me ferez pas croire qu’il ignore comment est financé le système de retraite public en France. Non, aucun moyen.
Il dit :

c’est nous les actifs qui finançons les retraites aujourd’hui.

Fabulation !

  • Seul 64 % des retraites sont financĂ©es par les cotisations sociales (Ă  noter que cette proportion est en constante baisse, 83 % en 2003 et 75 % en 2013).
  • 12 % des transferts pour issus du Fonds de solidaritĂ© vieillesse au titre de l’Aspa ou des trimestres portĂ©s aux comptes de salariĂ©s en arrĂŞt de travail.
  • 11,4% d’impĂ´ts et de taxes affectĂ©s.
  • 8,5% de transferts issus :
    • principalement, de la Caisse nationale des allocations familiales (Cnaf) au titre des avantages familiaux pour retraite,
    • de l’assurance chĂ´mage (UnĂ©dic) au titre de la validation des pĂ©riodes de chĂ´mage ;

Thanks for providing the text. Does your website use WordPress? If not, what type of editor/website is it? When I just paste your text into LanguageTool - LanguageTool, I cannot yet reproduce the problem.

Good evening to you.
Yes, I use Wordpress.
If that’s it, I’m currently migrating to Joumla, but it’s taking a long time, because the migration plugins from Wordpress are out of date.

Do you use WordPress at or an older self-hosted version? I’m asking because I still cannot reproduce the problem.

Hello, dnaber.
I am using the latest version of Wordpress installed in a virtual machine with Debian 11, Nginx and PHP-FPM and MariaDB on a fiber optic modem-router from my ISP.
The problem would be solved if LanguageTool had a language selector.
This is not a commandment, it’s just an opinion.

Good morning and good Sunday.

LanguageTool is back to change the language to English, but this time on a whole sentence and on Mozilla Firefox with the extension.

I have nothing against English in general, but when I write in French, it gives me hives.

Here is my sentence:

Oui, multiplateforme : GNU, Windows, Mac OS.

1 Like

Do you have Interlanguage enabled?

Hello, Lucas.
I didn’t find this in the preferences.
I did find something though.
In the preferences I have this:
Preferred languages:
I had put French and English, because when I write in English, it’s also good not to make mistakes.
I just tested it.
Well, that was that.
So if I want LanguageTool to correct correctly, I only need the language I type in the preferences and change as soon as I change the language.
Not practical, that!

1 Like

It’s there :point_down:

I think that LanguageTool team should place that option above all languages, even separate it if they want, as it’s not a language so it shouldn’t be in the language list in alphabetic order. It’s quite rare that users notice this option if it’s set between languages. But I read you didn’t set Interlanguage so I’m not aware of what’s changing the language by itself :thinking:.

Ha, okay.
I understand (not everything, but the general idea).
Since I’m diminished at the moment and afraid to say anything stupid, could you bring up the problem?

1 Like

Well, I can create an issue report on LanguageTool’s GitHub page for you with the issue explanation and the link of this your post so who knows a way to fix or developers want to update at least know about this. At least you should get some more attention to get help in fixing this problem. I’d have suggested you to create a GitHub account for you but it’s not the case just for 1 thing, that’s why I told you that I can do it for you. Tell me if you want me to post an issue report for you and I’ll show it once published.

Good evening, Luca.
I tried to explain you my situation, but DeepL Translator in fact, translating the opposite of what I wrote.
So I’ll make it simple and concise so that DeepL doesn’t say stupid things.
I have a GitHub account.
But, my medical situation does not allow me to do it personally.
So I accept your proposal to do it for me.
Nevertheless, if you or someone from GitHub needs to contact me, there is no problem.
Whatever my state is, I will answer you to the best of my ability.
Thank you very much.
I apologize for my difficulties.
Have a nice evening,

1 Like

Don’t worry, it’s fine :+1:. As I proposed, if you couldn’t, I’d have done it for you so here’s the issue report :point_down:

Hello, Lucas.
That’s it, I finally found the forum.
I’ve been looking everywhere for a few days.
I knew I had a question hanging over a forum. However, I couldn’t remember which topic and since I didn’t have the problem with LanguageTool anymore, the discussion didn’t remember me.
I will immediately bookmark the thread.
I just saw the request on GitHub, it’s perfect.
The crisis is gradually going away.
So I can relax and regain strength quietly.
Thanks again for your attention.

1 Like

Hello to all.
I have one more example:
I was writing an article about a software and I made the “stupidity” to put the list of required dependencies.
Then I decided to continue my article using the language of my article so in French.
And no, LanguageTool arbitrarily decided that I was not writing in French, but in English when even in the preferences, I only indicated French as the preferred language.
The change in LanguageTool happened when I typed “tar.gz”.
Have a nice evening.

1 Like

My opinion is that LanguageTool detects wrong words as written in other language because those detected ones are more or many compared to the total of the ones of the rest of the text, so if you write many English words rather than French words LanguageTool shows French words as wrong. I see this behavior many times as I write in a support forum and many mails so sometimes I write some examples in a language different from the set one. By the way, this behavior isn’t wrong, if a certain language is set I can’t expect LanguageTool to not underline them as wrong, it’s not set to ignore some words because the user is making some examples, explaining a rule or whatever.