Back to LanguageTool Homepage - Privacy - Imprint

[de] "Fehlermeldung, die geheimnisvoll ist"


(Jeremy S.) #1

Moin

Ich habe heute diese Fehlermeldung gekriegt, welche ich nicht nachvollziehen kann. Sie erzählt mir nicht, weswegen sie gekommen ist und das klicken der Okay-Taste lässt auch nichts abstürzen, worüber ich auch froh bin. Könnt ihr mir sagen, was diese Fehlermeldung zu sagen hat? Würde mich interessieren.

grafik

Grüße Dallun511


(Daniel Naber) #2

Wir bräuchten hier eine Möglichkeit, den Fehler nachzuvollziehen, also z. B. ein bestimmtes Dokument, bei dem das passiert.


(Jeremy S.) #3

Diesen Fehler nachzukon­s­t­ru­ie­ren, wird sehr schwer bis unmöglich, weil der Fehler sofort nach dem Start meines Roman kam, weswegen er einzigartig. Ich habe absolut keine Ahnung, wodurch dieser Fehler verursacht wurde.

Ich werde die Augen offen halten, aber ich bezweifele, dass mir diese Fehlermeldung wieder vor die Flinte kommt.

Grüße Dallun511


(Daniel Naber) #4

Falls es passiert, speichere bitte in dem Moment eine Kopie des Dokuments und schick sie an uns (gerne per E-Mail).


(Jeremy S.) #5

Sie ist zurück und sie kam dieses Mal bei meiner Story und nicht bei meinen Roman, weswegen ich euch die Komplette Story schicken kann.

grafik

Dort, wo der Cosur zu sehen ist, also am Ende der wörtlichen Rede, erblickte die Fehler, welche sehr geheimnisvoll ist, erneut das Licht der Welt.

Aber ich habe immer noch keine Ahnung, wodurch sie ausgelöst wird.
Ich habe das Dokument gesichert und ausgelager, damit ich trotzdem weiterschreiben kann, aber ich euch auch die Möglichkeit geben kann, den Fehler nachzukon­s­t­ru­ie­ren.

Es wurde LibreOffice Version 6 mit LanguageTool-20180316-snapshot benutzt

An welcher E-Mail oder wo steht die E-Mail an der ich die E-Mail schicken kann?

Grüße Dallun511


(Jeremy S.) #6

Wir sollten mal Sherlock Holmes anrufen, denn dieser Fehler wird immer merkwürdiger, denn jetzt erblickt schon das zweite Mal am diesen Tag das Licht der Welt und ich habe immer noch keine Ahnung, wieso.

Ich habe wieder das Dokument gesichert und werde es auch zur Verfügung stellen.

Grüße Dallun511


(Daniel Naber) #7

An die Adresse hier: https://languagetool.org/legal/


(Jeremy S.) #8

E-Mail wurde geschickt. Viel Glück.


(Jeremy S.) #9

grafik

Okay. So selten scheint sie nicht zu sein, denn jetzt ist sie zum dritten Mal gekommen und vorher kam noch eine andere Fehlermeldung. Meine Vermutung ist, dass es sich um eine Kettenreaktion handelt.

Grüße Dallun511


(Daniel Naber) #10

Danke. Das Problem tritt bei mir allerdings nicht auf. Wann genau passiert es, schon beim Laden oder beim editieren? Ist die Meldung immer genau die gleiche?

@Fred.Kruse ich verstehe nicht, warum der Stacktrace nicht vollständig ist, hast Du eine Idee, wie das passieren kann?


(Jeremy S.) #11

Das aller erste Mal kam der Fehler direkt beim Starten des Dokumentes. Beim zweiten Mal beim Schreiben und das dritte Mal bei Copy und Paste. Der Fehler kommt einfach beim normalen Bearbeiten und es ist immer der gleiche Fehler.

Die Bilder sind auch verschieden, aber die Meldung immer die gleiche.


(Fred Kruse) #12

Die einzige Idee, die mir spontan einfällt, ist, dass der Fehler in den Routinen auftritt, die nicht direkt gemeldet werden, sondern im Log-File stehen. Es wäre gut, sich den einmal anzusehen.
Ich bin im Moment aber unterwegs und kann mir das Problem erst Ende nächster Woche ansehen.


(Daniel Naber) #13

@Dallun511 Wenn der Fehler noch mal auftritt, sichere doch bitte die Datei .LanguageTool.log in Deinem Home-Verzeichnis und schicke Sie mir auch zu.


(Jeremy S.) #14

Ich werde meine Augen offenhalten und euch die Logdatei schicken, wenn der Fehler auftritt.

Grüße Dallun511


(Jeremy S.) #15

Schlechte Nachrichten.

Der Fehler schreibt sich gar nicht ins Log.

Grüße Dallun511


(Daniel Naber) #16

Probier bitte mal den aktuellen Snapshot (https://languagetool.org/download/snapshots/LanguageTool-20180323-snapshot.oxt), vielleicht ist da schon was gefixt.


(Jeremy S.) #17

werde ich garantiert versuchen.

Ich verstehe nur nicht, warum das Log leer ist.


(Jeremy S.) #18

Knapp acht Stunden im Betrieb und noch keinen Fehler gesichtet.
Ich melde mich, wenn der Fehler wieder gesichtet wird.

Grüße Dallun511


(Daniel Naber) #19

Wusste ich auch nicht, aber gibt wohl -XX:-OmitStackTraceInFastThrow, die in Ausnahmefällen dafür sorgen kann, dass wirklich ein Stacktrace generiert wird: https://stackoverflow.com/a/12582580/1582948


(Jeremy S.) #20

Freut mich zu hören, dass ihr die Fehlerquelle gefunden habt.

Grüße Dallun511