Back to LanguageTool Homepage - Privacy - Imprint

[DE] Multitasking-Problem

Moin @Fred.Kruse

Das LanguageTool hat das Problem, dass es grammatische oder stilische Fehler aus einem anderen Dokument exportiert und bei anderen Dokumenten importiert, wie in diesem Dokument. Es sind mehrere Dokumente offen, aber in diesem Dokument, wurde nie “ihr/du oder ihre” je großgeschrieben, trotzdem reagiert die Regel. Zudem reagiert die Regel, obwohl sie deaktiviert ist, wie


in diesem Beispiel. Das LanguageTool sagt immer, dass kein Fehler vorhanden ist, aber es trotzdem blau untertreicht.

Weißt du vielleicht, wie dieses Problem zustande kommt?

LO: 6.3.1.2
LT: LanguageTool-20190917-snapshot (Fehler ist schon länger vorhanden)
Java: 12

Grüße Dallun511

Hallo,
vielen Dank für die Meldung. Zu dem Problem gibt es aus meiner Sicht drei Punkte:

  1. Bisher kann ich den Fehler nicht nachvollziehen. Ich arbeite auch mit dieser ausgeschalteten Regel und häufig mit mehreren Dokumenten. Dass sich die Prüfung zwischen den Dokumenten mischt, habe ich bisher nicht beobachten können. Technisch halte ich das auch für sehr unwahrscheinlich, werde die Frage aber weiter beobachten und ihr nachgehen, wenn ich sie nachvollziehen kann.
  2. Vielleicht rührt der Fehler daher, dass die Regel doch nicht ausgeschaltet ist. Es hat in diesem Jahr eine Änderung gegeben. Wenn man über das Kontextmenü “Alle ignorieren” auswählt, gilt das nur noch für die aktuelle Sitzung. Nach einem Neustart von LO oder Auswahl von “Text erneut prüfen” wird die Regel wieder aktiviert (Das ist jetzt analog zur Rechtschreibprüfung). @Dallun511 kannst du bitte noch einmal prüfen, ob die Regel in den Optionen ausgeschaltet ist. Du findest sie unter Grammatikregeln / Groß-/Kleinschreibung / Einheitliche Verwendung von Du/du, Dir/dir etc.
    In der Version 4.8 plane ich in das Kontextmenü einen Menüpunkt “Regel deaktivieren” einzubauen, der dann die Regel in der Konfiguration dauerhaft ändert.
  3. @danielnaber die besagte Regel ist sicher für Briefe und E-Mails eine großartige Hilfe, für literarische Texte ist sie leider wenig geeignet. Es reicht, dass in einem Dialog im Text die Höflichkeitsform benutzt wird und im ganzen Rest des Dokuments werden Fehlmeldungen produziert. Ich würde daher dafür plädieren, dass sie unter der Kategorie “Briefe und E-Mails” einsortiert wird und standardmäßig deaktiviert ist.

Viele Grüße
Fred

Die Regel war zuerst wirklich nicht deaktiviert, aber jetzt ist sie deaktiviert und trotzdem wird in einem Dokument was blau unterstrichen, ohne Grund.
grafik
Das LanguageTool gibt kein Feedback!

grafik
Der Hacken ist gesetzt, dass auch die Grammatik überprüft werden soll.

Zwei Minuten Später:
Das Ergebnis:


Trotz Deaktivierung wird “ihre” blau unterstrichen in einem anderen Dokument.

@Fred.Kruse
Mit der Regel stimmt irgendwas nicht, denn sie lässt sich nicht abschalten.

Die Regel ist deaktviert und das schon länger und trotzdem werden “du/dir etc.” blau makiert.
LanguageTool-20190917-snapshot

Grüße Dallun511

PS Ich versuche es mit einer aktuellen Version nachzustellen, aber der Fehler exisitert schon länger. Siehe Github


LanguageTool-20190926-snapshot

Leider weiterhin vorhanden.

Ich habe alles mögliche ausprobiert, ich kann den Fehler nicht reproduzieren. Könntest du einen Screenshot von der Registerkarte “Allgemein” der LanguageTool Optionen posten?


@Fred.Kruse Bitte schön


LanguageTool-20191007-snapshot

@Fred.Kruse Konntest du neue Erkenntnisse sammeln?

Grüße dein Dallun511


Ich habe ein neues Beispiel des Problems gefunden. Hier wird "gerne im linken Dokument blau markiert, während gern im rechten Dokument nicht bemängelt wird.


Falls benötigt

Aber Dokument links gibt es nur gerne, und zwar einmal. Hier darf es nicht blau unterstrichen werden. Das LanguageTool vermischt die Analyse von mehrere Dokumenten, was sehr schade ist.

Nach wie vor kann ich das Problem nicht nachvollziehen. Auch nach vielfältigen Tests. Bei dem oben stehenden Beispiel sind zwei Dinge merkwürdig, Die Regel dürfte grundsätzlich nicht angewendet werden, du hast sie ja ausgeschaltet. Das mit der Durchmischung ist noch weniger zu verstehen, verschiedene Absätze müssten von LibreOffice vermischt werden. Das ist mir bisher noch nicht ein einziges Mal passiert.

Für das garantierte Ausschalten der in den Optionen abgeschalteten Regel habe ich jetzt noch eine Idee umgesetzt. Bitte probiere das obige Beispiel mit dem neuen Snapshot morgen noch mal aus.

Ich meinte vor allem das Beispiel mit der du/Du etc. Regel.

Dann werde ich mir den neuen Snapshot morgen herunterladen und testen.


LanguageTool-20191016-snapshot


LanguageTool-20191019-snapshot

Die “du/Du” Regel schlägt weiterhin an.
Bisher hat sie sich nicht in andere Dokument übertragen, aber das kann manchmal ein paar Stunden dauern, bis sie sich aufs nächste Dokument übertragt

@Fred.Kruse ab Mittwoch werde ich eine Schreibpause einlegen. Ich hoffe, dass das Problem gelöst ist, sobald ich wieder schreiben kann.

Grüße dein Dallun511

@Fred.Kruse konntest du das Problem bisher nachkonstruieren?



Es ist leider immer noch vorhanden.

Oder brauchst du irgendwas, um es nachzukonstruieren?

Grüße Dallun511

Leider kann ich das Problem nach wie vor nicht nachvollziehen. Kannst du mir mal die Dateien LanguageTool.log und LanguageTool.cfg posten. Du findest sie unter:

\Benutzer\<DeinBenutzername>\AppData\Roaming\languagetool.og\LanguageTool\LibreOffice

Wenn du in dem Verzeichnis \Benutzer\<DeinBenutzername> das Verzeichnis AppData nicht siehst, musst du im Windows-Explorer in der Registerkarte “Ansicht” die Option “Ausgeblendete Elemente” anhaken.

LT.zip (756 Bytes)

Ich hoffe, du findest damit das Probrem.