Back to LanguageTool Homepage - Privacy - Imprint

Desktop-/Offline-Version - included Server does not activate languagmodel (n-gram)


#1

I have installed LanguageTool 4.5 (2019-03-26 11:37, 204366e). I installed/copied the n-grams libraries and configured the corresponding settings, everything works fine in standalone mode, n-grams are checked etc.

But if I activate the server of the standalone version it will be started without the “languagmodel” option, no n-gram checks. I did not test word2vec. It is possible that “word2vec” will not be activated too.

If I start the command line version of the server with the languagemodel option, everything works as expected.


(Daniel Naber) #2

Thanks for the report, this should be fixed now (commit) and be available in the next snapshot.