Back to LanguageTool Homepage - Privacy - Imprint

DictionaryBuilder / -Exporter moved in 3.3? Command line options?


#1

Hi, i've just downloaded LT 3.3 and found that languagetool.jar v3.3 misses some classes that were still available in 3.2, e.g. org.languagetool.dev.DictionaryBuilder and org.languagetool.dev.DictionaryExporter. Maybe a build issue? Did they move to a different jar?

BTW, the wiki has some examples for DictionaryExporter expecting that class in package org.languagetool.tools instead of org.languagetool.dev. For 3.2, org.languagetool.tools doesn't work. For examples with dev, see the pages "Spell check" and "Developing a tagger dictionary".

Additionally, the example on page "Developing a tagger dictionary" has some command line options that aren't supported any more. In 3.2, the DictionaryExporter class seems to accept only one argument, the dictionary file itself, no -info or -o parameter.


(Andriy) #2

Yes, dictionary building classes have moved to https://github.com/languagetool-org/languagetool/tree/master/languagetool-tools and the package is now org.languagetool.tools


#3

Hi, thanks for your reply. But - in which jar are those classes? They aren't in languagetool.jar, and i didn't found them in any other jar in the current standalone version 3.3.


(Andriy) #4

languagetool-tools is not in maven central, you need to build https://github.com/languagetool-org/languagetool/tree/master/languagetool-tools yourself to have the latest version.
We were thinking to put the jar in the repository but usually you want to use the latest version from git not the last release.


#5

OK. Do i have to issue a specific maven command to build just those classes? I've build snapshot-3.4 from source yesterday, and the DictionaryBuilder / -Exporter classes were still missing from the created jars. Do i have to look for them anywhere else in the resulting target tree? Sorry for my dumb questions - i've already worked with java and ant, but i have very little experience with maven...


(Andriy) #6

You need to build languagetool-tools:
./build.sh languagetool-tools package
then you'll have a jar:
languagetool-tools/target/languagetool-tools-3.4-SNAPSHOT-.jar
(there's also another jar with all the dependencies in)


#7

Yippiieh - great, works perfectly fine! :sunglasses: Issue solved.