Back to LanguageTool Homepage - Privacy - Imprint

Different result between public API and my own built API


#1

I built LanguageTool 4.1 from git repository yesterday.
But I get the different result from public API, which is also 4.1-SNAPSHOT.

I run the following command to start API server according to the site guide:
-> java -cp languagetool.jar org.languagetool.server.HTTPServer --port 8081

My own result:
curl --data “language=en-US&text=I have a bed news” http://localhost:8081/v2/check
{“software”:{“name”:“LanguageTool”,“version”:“4.1-SNAPSHOT”,“buildDate”:“2018-01-24 07:02”,“apiVersion”:1,“status”:""},“warnings”:{“incompleteResults”:false},“language”:{“name”:“English (US)”,“code”:“en-US”},“matches”:[]}

Public API result:
curl --data “language=en-US&text=I have a bed news” https://languagetool.org/api/v2/check
{“software”:{“name”:“LanguageTool”,“version”:“4.1-SNAPSHOT”,“buildDate”:“2018-01-24 21:01”,“apiVersion”:1,“status”:""},“warnings”:{“incompleteResults”:false},“language”:{“name”:“English (US)”,“code”:“en-US”},“matches”:[{“message”:“Statistics suggests that ‘bad’ (opposite of ‘good’) might be the correct word here, not ‘bed’ (place to sleep). Please check.”,“shortMessage”:"",“replacements”:[{“value”:“bad”}],“offset”:9,“length”:3,“context”:{“text”:“I have a bed news”,“offset”:9,“length”:3},“sentence”:“I have a bed news”,“rule”:{“id”:“CONFUSION_RULE”,“description”:“Statistically detect wrong use of words that are easily confused”,“issueType”:“non-conformance”,“category”:{“id”:“TYPOS”,“name”:“Possible Typo”}}}]}

I don’t know why there is a difference between them.
There is something for me to do additionally.
I think that maybe a different rule file is used in my own API.

Please give me advice to solve this problem.
Thank you.


(Lodewijk Arie van Brienen) #2

look at the build-Dates, your using a slightly older (and possibly buggier) build of LT 4.1


#3

Today after updating codes, I also get the different result from the public API.
(build date: 2018-01-25 04:04)

The following is the process which I run to build.

  1. $ mvn clean test
  2. $ ./build.sh languagetool-standalone package -DskipTests
  3. $ java -cp languagetool-server.jar org.languagetool.server.HTTPServer --port 8081

(Daniel Naber) #4

Please see https://languagetool.org/compare/, your server is basically described in the column “LT stand-alone”.