Back to LanguageTool Homepage - Privacy - Imprint

Disable auto language detection

I write in English almost exclusively, but the extension often randomly tries to check my text as German/Spanish/etc (which I never use).
This mostly happens for shorter text snippets, but it’s still quite annoying.
I was wondering if there is a way to disable the language detection and always use English by default (or as an alternative - heavily bias the detector to “English by default unless it really does not seem like it”)

Not quite, but this should help: https://languagetooler.freshdesk.com/en/support/solutions/articles/44001932886 - please let us know if it doesn’t (examples of incorrectly detected texts will help us understand the issue then).

Hey, thanks for the suggestion!
I already have only English in the browser settings though =
image

Here is one example of incorrect language detection, will add more in a bit (posting separately because of new user limits):
image

Thanks - was “Have fun!” the complete text or was there more?

That was the complete text in that text field

I cannot reproduce the issue yet. If you try again, does it still happen? If so, could you send feedback via the “Send feedback” link in the add-on? This will transfer some more information, like the exact browser version etc.

Another example image
I’ve just done “send feedback” for this one.

Potentially important - I’m connecting to the local server version of LanguageTool (v5.3)

Have you set fasttextModel and fasttextBinary in your properties files (--config lt.properties)?

No, I’m running with all default settings

Without those settings, language detection quality will be worse than on languagetool.org.

I see. I’ll try setting that up, thanks for your help!
(I wish I could just disable it though)

So it still sometimes happens, but far less often vs previous settings. Thanks for your help!