Back to LanguageTool Homepage - Privacy - Imprint

Disable morfologik spell check in LT server for Texstudio


(David Ho) #1

Hi I am using Texstudio with standalone LT server on Ubuntu.

I have been trying to remove the duplicate dictionary check from LT. Texstudio by default uses Hunspell and I have been adding new words before I installed LT.

I include the --config option to the HTTPServer with the following property file content.

# disable spell check
disabledRules = MORFOLOGIK_RULE_EN_US

It is not working, the above rule is still popping up for words that were added to Hunspell. Can someone tell me what I missed?

Thank you,
David


(Daniel Naber) #2

disabledRules is not an option in the properties file. It needs to be set as parameter by the software that calls LT via HTTP. I’m not sure if there’s a solution for your issue other than TeXstudio adding this feature. You could try to assign just en as a language - if LT gets en (instead of e.g. en-US), it won’t run the spell check.


(David Ho) #3

Thanks @dnaber, I will let the Texstudio devs sort this out before I try again. It’s not a show stopper.