Back to LanguageTool Homepage - Privacy - Imprint

Disabling rules from the command line isn't working


(Jake Cahill) #1

Hello,

I’m running this line in the command line:
java -jar languagetool-commandline.jar -l en-GB --enable "PROJECT_NOT_APPROVED_screen" C:\Users\Jake\Desktop\term-checker-test.txt

According to the docs, the --enable flag should include only those rules in the results. But, it’s not working.

I still get these rules in the results:
STE_APPROVED_POS_display_DISPLAYS
STE_RULE_1_2_POS-noun-singular

Can anyone help?

Thanks


(Daniel Naber) #2

You’ll also need to use -eo (see http://wiki.languagetool.org/command-line-options).


(Jake Cahill) #3

Thanks @dnaber! Is it normal that the results of the command line don’t include examples, but the results of the UI do?


(Daniel Naber) #4

Yes, that’s the way it is.