Back to LanguageTool Homepage - Privacy - Imprint

Double-clicking languagetool.jar does not launch program


(Mark Dennett) #21

Thanks for your advice. I have tested some other jars, and they behave in the same way. I tried what you suggested, but this had no effect. .jar files are still associated with java.


(Lodewijk Arie van Brienen) #22

I forgot one step:
delete HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.jar

this forces Windows to use the default actions for .jar (though a system-restart may be needed for this to take effect)


(Mark Dennett) #23

Still no luck I'm afraid. I restarted the PC, but still get the same problem: a black window is displayed for a fraction of a second, and then nothing. The tool still works OK from the command line.


(Jan Schreiber) #24

That's an almost sure sign Java is invoked without the necessary -jar parameter. Most likely Java does run, says it can't find the main class, and exits immediately. This happens so fast you only see the black box (a command line window) flash up. This problem isn't uncommon, but it usually isn't so difficult to solve.

As a workaround, you can

  • in Windows Explorer, right-click in the folder where languagetool.jar is located,
  • create an empty text file and open it,
  • enter java -jar languagetool.jar,
  • save the file as e.g. LT.bat (without the .txt extension!),
  • double-click LT.bat to start LanguageTool.

(Mark Dennett) #25

Thanks very much, this worked perfectly. One possible clue: when I removed the references to .jar files in the registry, I noticed that languagetool.jar was being associated with the "Office XML Handler" program. I was expecting to see no program association after having updated the registry, so wondered if this might be evidence of the problem.