Back to LanguageTool Homepage - Privacy - Imprint

[en]LanguageTool(LT) 4.7 in LibreOffice(LO) can't use remote server (Produces exception)

As in the title, whenever I enable the ‘Use remote server to check text’ and enter ‘http://localhost:8081/v2’, a bunch of errors pops up. Unfortunately, I cannot copy the text but all of them are stating a java NullPointerException, leaving me with no choice but to disable that option. It happens even with ‘http://127.0.0.1:8081/v2’ and ‘http://127.0.0.1:8081’. I didn’t try it with ‘http://localhost:8081’ as I assume 127.0.0.1 and localhost are the same.

I have a local LanguageTool server running on my machine on port 8081, and the LanguageTool Firefox extension installed and pointed to the local server. Last I checked, they were working fine.

Other than those errors, LanguageTool was working fine on LibreOffice. I configured it correctly and tested it with the example document. That was the only issue I faced with the plugin. The only reason I want to use the local server was to reduce memory consumption. Both are using the ngram and word2vec data.

If needed,
Operating System: macOS High Sierra v 10.13.6
Java Runtime Environment: AdoptOpenJDK jre8 hotspot (1.8.0_222)
LibreOffice version: 6.2.7.1
LanguageTool plugin version: 4.7
LanguageTool server version: 4.7 (using GUI)

I searched all over the forums and on GitHub, none of which had any solutions to the issue I am facing. Any help provided would be greatly appreciated.

I apologize if my English is bad.

Could you send a screenshot of the error? The exact error message will help a lot to analyze the issue.

Hope this helps.

Also, several more error messages pop up whenever I edited the document in any way or change the cursor position, prompting me to turn off that option.

This might have been fixed already, could you try with a current snapshot, like this one? https://internal1.languagetool.org/snapshots/LanguageTool-20191019-snapshot.oxt

One question, am I supposed to include the /v2 in the server URL? (As in http://localhost:8081/v2) I still got some errors.


snapshot 2019-10-19


snapshot 2019-10-18


snapshot 2019-10-15

I hope @Fred.Kruse can help with that.

The correct string is http://localhost:8081. (WITHOUT “/v2”).
The nullpointer exception I can not reproduce. Could you please download the last version of LanguageTool and try it again?
The version of the server and of the LO extension has to be the same.

I’ve tried it, still, there are errors.

Both are the same (LanguageTool 4.7 (2019-09-28 10:09, 64f87c1)).

I’ve found the bug. Please update LT tomorrow

Whoops… Sorry for being late!

I’ve installed the latest snapshot for the LibreOffice plugin, and it seems (so far) to be working fine. No error messages showed up, and it was able to detect the errors in the test document. I will report back to this thread if I catch any more issues. Thank you for fixing it!