Back to LanguageTool Homepage - Privacy - Imprint

Error on submission


(shilpa) #1

I am trying to work on the "Integration on Websites" integrated and when am trying to evaluates the text its throwing a error stating "There was a problem communicating with the service. Try again in one minute."; Can you please help us on this.


(Daniel Naber) #2

Is this on a public website? If so, please post the URL so I can have a
look. If not, you'll need to use Firebug (https://getfirebug.com) to
debug this, i.e. look at its network tab to see what happens.

Regards
Daniel


(shilpa) #3

I am getting an error:

XML Parsing Error: no element found Location: moz-nullprincipal:{1e51140f-9aaa-4031-922a-f265319d030d} Line Number 1, Column 1:


(Daniel Naber) #4

Can you see what the actual response is? You can use the "+" in Firebug
to open the request and then look at the Response tab. Where does the
request go? Does it look correct?


(shilpa) #5

I am not getting any response TAB there. I can see Headers, Post, Params, XML, Cookies tab here and on XML tab am getting an error as "XML Parsing Error: no element found Location: moz-nullprincipal:{40c072c7-caa4-446b-9165-c6a1a14c8d08} Line Number 1, Column 1:" please suggest


(shilpa) #6

Hello,

My Code is simple please check below:











rows="6">Paste your own text here... or check check this text.



English
German
Italian

value="Check Text" onClick="doit();return false;">



I am not getting any response from the API. Waiting for your reply on this.


(Daniel Naber) #7

I have added information about how to debug the proxy script to
http://languagetool.org/website-integration/ (see section 'PHP Proxy').
I'm sorry setup is so complicated, making it easier is on our long-term
TODO list. For now, I can only refer to our documentation and offer to
have a look at your page, but that only works if it's on a publicly
accessible URL.

Regards
Daniel


(shilpa) #8

Thank you for your info. I Have my URL online. Now am getting a Response as "No Error Found" , though i have error in my provided input - "Paste your own text here... or check this text too see an few of of the problems that LanguageTool can detecd.".


(shilpa) #9

Hello, Fine thank you its working fine for me now :smile: Thanks for your time and support.

Regards
Shilpa


(Daniel Naber) #10

Please let us know what the problem was so others reading this thread
can avoid running into the same issue.

Regards
Daniel