Back to LanguageTool Homepage - Privacy - Imprint

Expected text language: English (GB) (no spell checking active warning


(mvalle) #1

Using latest LT (4.2) on Windows
I want to check a single rule from commandline:

java -jar "C:/apps/LanguageTool-4.2/languagetool-commandline.jar" \
	 -l en-GB -c UTF-8 -m it -eo -e DASH_RULE mytext.txt

Always this output the following, seems harmless, warning:

Expected text language: English (GB) (no spell checking active,
specify a language variant like 'en-GB' if available)

But I specified a language! So what does it means this message? What should I do?

If I remove the -eo and -e RULE options the message disappears.

Another rule MORFOLOGIK_RULE_EN_GB instead gives a slightly shorter warning:

Expected text language: English (GB)

Strange.
Thanks for your help!
mario


(Daniel Naber) #2

Spell checking is not active because you have only turned on the DASH_RULE and not other rule, i.e. the spelling rule is turned off, too. I have improved the message not to mention language variants for your case.


(mvalle) #3

Now understand (and don’t understand).
If I add MORFOLOGIK_RULE_EN_GB to my rule the warning about spell checker disappears. This is the part that I understand.

What I don’t understand is the goal of the warning. Shouldn’t I run a rule at a time?
Because this is the goal of my attempt: to have the results of each rule in a separate result file to fix all related problems and ignore “not useful” suggestions (like PUNCTUATION_PARAGRAPH_END).
Anyway, thanks for the suggestion!
mario


(Daniel Naber) #4

Many people think en is a valid language code - and it is, but it will not activate the spelling rules. It can’t, because it doesn’t know whether to use en-US or en-GB. Thus the warning, as most users expect spell check to be active.

Then using -e and -eo while ignoring the warning looks fine to me.