Back to LanguageTool Homepage - Privacy - Imprint

Flag to disable running LT on website

Hi there :slight_smile:

I work as a software engineer on splashthat.com, which has a CMS with an RTE that conflicts with the code injected with LT. It results in some weird situations, where the LT markup stays on the HTML contenteditable div after focusing out from the editable text areas, which is a bit annoying for the user. Attaching an example.

Is it possible to add a meta tag, or JavaScript line, that would disable LT on the current frame?

I’ve searched through the docs, but haven’t found something related to this yet.

Thanks

You can use data-lt-active="false" on the affected element. We’ll see if we can fix this, though.

Thanks! I’ll give it a try during the week and confirm it worked as expected.

Confirmed, thank you @dnaber

Ah, sorry for the spam. I forgot to mention something relevant, @dnaber

The reason why I opened this thread is that disabling the extension didn’t work. LanguageTool still was applying to the editable texts in the CMS, despite it being disabled. See the attachment.

I suspect this is because the text editing happens within an HTML iframe element that has a different URL. Possibly LanguageTool’s extension is only disabled on the parent frame, but not in iframes loaded inside the page.

I managed to block LT on my page by doing this:

  function _disableLt() {
    window.document.getElementById('checktext_ifr').contentDocument
            .getElementById('tinymce').setAttribute("data-lt-active", "false");
  }

  tinyMCE.init({
     oninit: _disableLt,