Back to LanguageTool Homepage - Privacy - Imprint

French - Adding words to the POS tagger in added.txt, doesn't seem to work


(SP) #1

Hello all again,
I know I'm asking a lot of questions during these days.
So, this is the today problem:

in my French dictionary file there's the word ---> "voilà"
when I launch the pos tagger ---> voilà\null

I tried to add the word in added.txt using tabs (as described in http://wiki.languagetool.org/tips-and-tricks#toc25) --> voilà voilà A
then I launched again the pos tagger but the result is always "null".

Why?


(Daniel Naber) #2

I've just tried this (adding voilà voilà A to added.txt, with tabs) and it works for me. Did you make sure your editor keeps the tabs and doesn't replace them by spaces? Did you restart LT after that change?


(SP) #3

Thank for the reply. I'll check if my editor keeps tabs (I don't know how!).

Restart i.e. should I start mvn package again or just quit the windows cmd and restart it ?


(Daniel Naber) #4

For changes in added.txt it's enough to restart LT, no re-compilation is needed (Lt itself needs to be restarted, not the cmd it's running in).