Back to LanguageTool Homepage - Privacy - Imprint

[Google Docs] add-on missing option to check

Hi!
I used this addon a lot. Recenty I noticed that when I go to Addins -> Grammar and spell checker -> there is no longer option to “check”. Only “Help” left.
Tried to remove it and add again. Updated google chrome to latest version, also does not work on firefox.
Does anyone know how to solve it?

Here’s one solution to a similar but not identical issue, does this apply maybe?

“This is caused by users being logged in with two or more different accounts and Google Docs uses the wrong one (the one where the add-on doesn’t have permission). Workaround: use incognito window or log out from all accounts except one. Details at https://sites.google.com/site/scriptsexamples/home/announcements/multiple-accounts-issue-with-google-apps-script

In any case, we have added some code that might fix that, will be part of the next release (maybe next week, but I can’t promise it).

Hi thanks, I did not help. I think I found the reason. The text is too long, in other, shorter documents it works. I could bet that it worked in longer text previously, but I had to highlight small piece of text to check it. Now I can see that there is option to buy premium, so I suppose this option has been removed, am I correct?

That’s strange. Behavior in this regard should not have changed - you should be able to select parts of the text to get them checked, as with previous versions. I’ve forwarded your analysis to our developer.

Thank you!

Hi, Now something changed. I am able to start the right section. I have error : The add-on doesn’t have permission to operate here. Please make sure that you’re using the add-on with the same Google account you installed it from. If that doesn’t help, try reinstalling the add-on.

Reinstalled, but it did not help, any tips?

Do you have more than one Google account? Could you try logging in with an incognito window, does it work there?

Hi, I have only one google account. However the document is shared, I removed the permision to edit the document to my firends, and it did not help. Incognito mode does not change anything.