Back to LanguageTool Homepage - Privacy - Imprint

Grammar check for Dutch broken

I use the current LibreOffice extension LanguageTool 5.2.2 on both macOS Catalina and Ubuntu Budgie. I mainly create documents in the following languages: Dutch (Netherlands), German (Germany) and English (UK & USA).

Yesterday I noticed that the grammar check by the LanguageTool no longer works if the language of the respective document is set to Dutch. For documents with German or English language settings, on the other hand, the LanguageTool works perfectly. This error occurs under macOS as well as under Ubuntu.

Under macOS, this error is even more serious. The default language setting on my laptop with Ubuntu is German, the one on my iMac is Dutch. Therefore, when I want to create a new document in LibreOffice on my iMac, the language is automatically set to Dutch. However, with the default language set to Dutch, the LanguageTool does not even load properly. For example, if you want to call up the LanguageTool settings in the menu, LibreOffice hangs and then has to be stopped forcibly because the application no longer reacts. In addition, the entry for selecting the profile is missing in the menu. However, if I set the language of the document to German or English, the LanguageTool is loaded completely with all the menu entries and then works perfectly again.

With the update to the latest version, an error must have crept into the LanguageTool, at least with regard to the changes for the Dutch language.

Can you reproduce and confirm this error?

Is there an error message?
I checked myself. I had 5.1.1 running on Kubuntu and LO. No issues. After getting 5.2.2 from the download site, Starting LT gives the message ‘LinguisticDervices Failed!’

For a fast solution, I would suggest a downgrade :wink:

Thank you very much for your reply. However, I have to disappoint you, unfortunately the LanguageTool does not show an error message. If the language is set to Dutch, the extension is simply not loaded. If you then try to call up the extension’s settings or click on the About menu item, LibreOffice simply hangs, which results in the unloved spinning beach ball for Mac users. In such a case, one has no choice but to forcibly stop LibreOffice with the key combination Command + Option + Escape. This in turn generates a long and incomprehensible macOS error message, which is automatically sent to Apple.

Addendum: For now, I too have switched back to the last version of the LibreOffice extension that worked for me, namely LanguageTool 5.1.1. In this version, the extension is also fully loaded for the Dutch language without crashing LibreOffice. Version 5.1.1 may not have the latest updates for the language rules, but at least it works perfectly in each of the three languages for which I need the LanguageTool.

I guess the programmers will have to look into this. I will trigger them, since it is specific to Dutch.
@Fred.Kruse: Could you please have a look at this, and if you find out it has something to do with Dutch, please inform me what the cause is.

1 Like

Good news! By chance I discovered today that a new version of the LanguageTool extension is available for download in the LibreOffice Extension Center. In the meantime I have installed and briefly tested LanguageTool 5.2.3 in LibreOffice 6.4.6.2 under Ubuntu Budgie 20.04.2 as well as in LibreOffice 7.1.0.3 under macOS Catalina. And I can confirm that the LanguageTool extension on both systems now works perfectly again under Dutch language settings.

Great. If you feel like giving feedback to the Dutch rules, please feel free to do so. We love feedback; it makes things better.

1 Like