Back to LanguageTool Homepage - Privacy - Imprint

Grammar not checked in context

I changed “advice” to “advise” which changes the complete context and is wrong but languagetool did not detect. Advice is a noun while advise is a verb and usage is completely different.

Please post the complete sentence. Without that, we cannot debug this issue.

Here is the complete sentence

I got some invaluble advise today

The only error detected was

Starting check in English (American)…

1. Line 1, column 12
Message: Possible spelling mistake found (deactivate)
Correction: invaluable
Context: I got some invaluble advise today

Potential problems found: 1 (time: 42ms)
How you can improve LanguageTool

What does the “deactivate” link do?

Once you have fixed that error, the other issue will be found.

It deactivates the rule (the spell checking rule in this case, so it’s usually not a good idea to deactivate it).

I fixed the error
I got some invaluable advise today

and still it didn’t detect the grammar error

Starting check in English (American)…

Potential problems found: 0 (time: 45ms)
How you can improve LanguageTool

Then you’re probably not using the ngram data, see https://languagetool.org/compare (“Additional homophone rules”)

I’ve installed directly from languagetool.org so it is using the homophone data as per your link.
Then why it is not checking grammar?

It’s only using the ngram data if you have installed that data, not automatically (see http://wiki.languagetool.org/finding-errors-using-n-gram-data).

But how is a user supposed to know that ngram data for grammar checking is a separate install?
Even in that comparison table nothing is mentioned about that.
Maybe you should mention a note along with the table that ngram data for grammar checking is a separate install.

The table says “only when installed manually” with a link.

ok. I guess I was looking at the wrong column :frowning:
Where is the documentation of all commands I can use with languagetool?
Can I count the number of words in a sentence using python?
Can I check grammar using python?

I downloaded and installed the ngram data, set the ngram directory path and now when I doubleclick languagetool.jar it does not run at all.
Earlier it would run
Why???

Please start it on the command line (java -jar languagetool.jar) to see the error message.

IT’s giving out of memory error even when nothing else is running. Why???

E:\partha\LanguageTool-4.8>java -jar languagetool.jar
Warning: At the moment, your platform (Windows) is not supported by the official XGBoost maven package; ML-based suggestion reordering is disabled.
Exception in thread “AWT-EventQueue-0” java.lang.OutOfMemoryError: Java heap space
at org.apache.lucene.util.fst.FST.(FST.java:387)
at org.apache.lucene.util.fst.FST.(FST.java:313)
at org.apache.lucene.codecs.blocktree.FieldReader.(FieldReader.java:91)
at org.apache.lucene.codecs.blocktree.BlockTreeTermsReader.(BlockTreeTermsReader.java:231)
at org.apache.lucene.codecs.lucene50.Lucene50PostingsFormat.fieldsProducer(Lucene50PostingsFormat.java:446)
at org.apache.lucene.codecs.perfield.PerFieldPostingsFormat$FieldsReader.(PerFieldPostingsFormat.java:261)
at org.apache.lucene.codecs.perfield.PerFieldPostingsFormat.fieldsProducer(PerFieldPostingsFormat.java:341)
at org.apache.lucene.index.SegmentCoreReaders.(SegmentCoreReaders.java:104)
at org.apache.lucene.index.SegmentReader.(SegmentReader.java:65)
at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:58)
at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:50)
at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:731)
at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:50)
at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:63)
at org.languagetool.languagemodel.LuceneSingleIndexLanguageModel$LuceneSearcher.(LuceneSingleIndexLanguageModel.java:242)
at org.languagetool.languagemodel.LuceneSingleIndexLanguageModel$LuceneSearcher.(LuceneSingleIndexLanguageModel.java:230)
at org.languagetool.languagemodel.LuceneSingleIndexLanguageModel.getCachedLuceneSearcher(LuceneSingleIndexLanguageModel.java:183)
at org.languagetool.languagemodel.LuceneSingleIndexLanguageModel.addIndex(LuceneSingleIndexLanguageModel.java:119)
at org.languagetool.languagemodel.LuceneSingleIndexLanguageModel.(LuceneSingleIndexLanguageModel.java:95)
at org.languagetool.languagemodel.LuceneLanguageModel.(LuceneLanguageModel.java:65)
at org.languagetool.Language.initLanguageModel(Language.java:162)
at org.languagetool.language.English.getLanguageModel(English.java:166)
at org.languagetool.JLanguageTool.activateLanguageModelRules(JLanguageTool.java:492)
at org.languagetool.gui.LanguageToolSupport.activateLanguageModelRules(LanguageToolSupport.java:271)
at org.languagetool.gui.LanguageToolSupport.reloadLanguageTool(LanguageToolSupport.java:259)
at org.languagetool.gui.LanguageToolSupport.init(LanguageToolSupport.java:318)
at org.languagetool.gui.LanguageToolSupport.(LanguageToolSupport.java:109)
at org.languagetool.gui.Main.createGUI(Main.java:470)
at org.languagetool.gui.Main.access$1700(Main.java:144)
at org.languagetool.gui.Main$7.run(Main.java:1203)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)

Use e.g. java -Xmx2000M -jar languagetool.jar to increase memory for Java.

It gives error

E:\partha\LanguageTool-4.8>java -Xmx2000M -jar languagetool.jar
Error occurred during initialization of VM
Could not reserve enough space for 2048000KB object heap