Back to LanguageTool Homepage - Privacy - Imprint

How to disable "This sentence does not start with an uppercase letter" xxz


(jrow) #1

I'm trying to skip the verification that checks if a sentence starts with a capital letter. I could not find that specific rule in the grammar.xml file (for ES). If I uncheck this option using the GUI, the check is not included while using the GUI - but if I use LT in server mode, I still get results for missing uppercase letters at the beginning of a sentence.

What's the file I need to modify to change this? Why LT behaves differently when you run the GUI and when you run it as server?

Thanks!


(Daniel Naber) #2

The server cannot be configured, but you can send with every request which rules to disable, like this:

http://localhost:8081/?language=es&disabled=UPPERCASE_SENTENCE_START&text=my+text

(jrow) #3

Thanks, Daniel.
I'm actually using LT from Okapi's Checkmate, so I believe there's no way to change the request. Do you know if this is possible?


(Daniel Naber) #4

Actually, if you start the server from the GUI and check "Use above settings for the server" the GUI settings should be active for the server, so what I said above wasn't totally accurate. Or did you try that?


(jrow) #5

Yes, I did, but apparently the "Use above settings for the server" has no effect. We tested this in more than one computer. It looks like if you run LT as a server, all the Options from the GUI are ignored. That's why I was trying to find out if this could be done by, say, commenting out some rule.


(Daniel Naber) #6

There's indeed a bug. I'll put that on my TODO list. Anyway, you cannot disable this very rule by editing a file because it's a Java rule, not a rule that appears in an XML file.


(Daniel Naber) #7

The bug ("Use above settings for the server" being ignored) should now be fixed, i.e. the fix should be in tomorrow's snapshot at https://languagetool.org/download/snapshots/?C=M;O=D. Please let me know if it works for you.


(jrow) #8

Daniel, my colleagues have tested this and apparently works perfectly.
Thank you so much for taking action so quickly. This will definitely help us get better results from LT.