Back to LanguageTool Homepage - Privacy - Imprint

Installation problem


#1

Hi!

I have LO 5.3.3.2 and downloaded rel 3.8.
Get errors when updating from 3.7 and opening .oxt like this:

(com.sun.star.uno.RuntimeException) { { Message = "[jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.UnsupportedClassVersionError: JVMCFRE003 versione principale errata; classe=org/languagetool/openoffice/Main, offset=6\X000ajava stack trace:\X000ajava.lang.UnsupportedClassVersionError: JVMCFRE003 versione principale errata; classe=org/languagetool/openoffice/Main, offset=6\X000d\X000a\X0009at java.lang.ClassLoader.defineClass(ClassLoader.java:275)\X000d\X000a\X0009at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:74)\X000d\X000a\X0009at java.net.URLClassLoader.defineClass(URLClassLoader.java:540)\X000d\X000a\X0009at java.net.URLClassLoader.defineClass(URLClassLoader.java:451)\X000d\X000a\X0009at java.net.URLClassLoader.access$300(URLClassLoader.java:79)\X000d\X000a\X0009at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:1038)\X000d\X000a\X0009at java.security.AccessController.doPrivileged(AccessController.java:362)\X000d\X000a\X0009at java.net.URLClassLoader.findClass(URLClassLoader.java:429)\X000d\X000a\X0009at java.lang.ClassLoader.loadClassHelper(ClassLoader.java:703)\X000d\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:682)\X000d\X000a\X0009at java.lang.ClassLoader.loadClassHelper(ClassLoader.java:695)\X000d\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:682)\X000d\X000a\X0009at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:1069)\X000d\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:665)\X000d\X000a\X0009at com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:53)\X000d\X000a\X0009at com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:376)\X000d\X000a", Context = (com.sun.star.uno.XInterface) @0 } }

Downloaded and installed jre-8u131-windows-i586 as no JRE in LO Options and tried all directories with no success.

Thanks for any help.


(Andriy) #2

After you install JRE do you see it in the LO options and is it selected? Note: your JRE architecture (i586 or x86_64) must match your LibreOffice.org


#3

Hi Andriy.

After installing jre-8u131-windows-i586 I do not see it in the LO options. LO installed using LibreOffice5.3.3_Win_x86_.

My LO rel 5.3.3.2
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448


(Lodewijk Arie van Brienen) #4

A. Did you fully restart LO? (Many programs only check the installed java during program-load)
B. Perhaps a reboot is needed for the last few files to be adjusted.