Back to LanguageTool Homepage - Privacy - Imprint

Installing LanguageTool as an offline add-on to Firefox


(Daniel Naber) #21

Can you upload your HTML with the CKEditor somewhere so we can check?


(Kevin Schafer) #22

Here is a download link for a Zip folder: kms’ html

Just simply unzip and place the inside “project” folder on your desktop and open the index in Firefox and you should be good to go. The CKEditor interaction is specifically on lines 7 & 32. Everything else is just standard old school.


(Daniel Naber) #23

The editor in your example uses spellcheck=false and thus the LT add-on turns itself off.


(Kevin Schafer) #24

Okay, I have results. They’re just not exactly what I had hoped.

Here is the code snippet that I found in the ckeditor.js file, less the quotes: “CKEDITOR.config.disableNativeSpellChecker=!1;” It was set to “0” and I set it to “1.” Now we have red waves beneath misspelled words in the rich text editor pane. The only thing is, I need to type in “Source” mode, then I click back to the rich text pane. There, a misspelled word is indicated; however, if I click anywhere in the rich pane, the line of text jumps down and the red indication goes away. I click back to “Source” mode and now formatting has been added automatically, such as p> and /p> (with front ducks). The formatting is knocking out LT.

I mostly like the rich text editor because I can easily add a photo or image with a caption, as well as easily add a special character to my text. I have disabled CKEditor, which left me with only a textarea for inputting my text. I thought LT would work, but it doesn’t. The small icon in the lower right-hand corner with the blue wave shows, but not the blue check mark.

Do you recommend TinyMCE, at least as a form of testing to see what can become of this?


(Kevin Schafer) #25

UPDATE: I did not know that I had to right click within my textarea to highlight misspelled words. LT is working just fine in a plain textarea by doing this.

I enabled CKEditor and once again entered text. In “Source” mode, among the formatting tags, LT catches the misspelled words when right clicking in the pane. It still doesn’t function in the rich text pane.

This is still positive headway.

Another UPDATE: I also discovered that if I place my cursor over the misspelled word when I right click, a drop down menu appears with a list of properly spelled words from which I can choose. This is amazing work by LanguageTool and its team. It’s actually a lot of fun.

I will keep you posted. Thank you a ton.
kms