Back to LanguageTool Homepage - Privacy - Imprint

Installing LanguageTool as an offline add-on to Firefox


(Kevin Schafer) #1

Hello.

This is my first post here. I’m working on a web project that is taking place on an offline computer running XAMPP with Win7. I have the latest Firefox version that I use for developing my site.

I found out about LanguageTool and I would really like to try it as an offline add-on to Firefox. I downloaded the LanguageTool 3.2 Zip folder and I currently have it on my desktop. I extracted the inner folder, LanguageTool-3.2, and found the languagetool.jar file. I was able to try it out and it works for me.

Could someone please walk me through installing LanguageTool in Firefox for my offline development?

Thank you for your time. I appreciate it.

kms


(Daniel Naber) #2

Please see the “Offline use” at https://addons.mozilla.org/en-US/firefox/addon/languagetool/ - does that address your question?


(Kevin Schafer) #3

Hello Daniel,

Thank you for your reply.

I did run across that installation guide several times in the last couple of days. To be honest, I’m an experienced computer user, just not experienced at things such as command lines and browsers.

I code HTML/CSS and I’m teaching myself PHP, but I could use some help at adding LanguageTool to Firefox.

kms


(Daniel Naber) #4

Please let us know what you have done so far and where exactly you need help.


(Kevin Schafer) #5

Daniel,

I have a CRUD search which is powering a dictionary. I bought a 1913 Webster’s Dictionary database in CSV form. I was surprised to learn that when their copyright dropped off, the material was made available to the public. There’s a good 105 years worth of updates to be made. I do have a full hosting plan online, but it’s nice having XAMPP on a computer at my desk without relying on an Internet connection.

I’d rather not type everything into a word processing program, only to copy and paste it into the textarea of my web application. I just thought if LanguageTool could be added to Firefox, it would certainly help make entries into my dictionary a lot faster and smoother – and accurate.

I’ve been in the printing business since the age of 12 in 1980, and I absolutely enjoy being around dictionaries and encyclopedias and words. I have stacks of those books – and electronic ones as well. My oldest dictionary is from 1876. There are no dog ears on any of the pages, but the corners of the covers are worn round, right down to the corners of the pages. The pages and covers have been worn even further, together.

When is comes to tapping away at a keyboard, a little help with spell checking and grammar can go a long way for accuracy.

Thanks,
kms


(Daniel Naber) #6

Have you installed https://addons.mozilla.org/firefox/addon/languagetool/ in Firefox? Does it work as expected? Once it does, you just need to change the URL in the “experimental settings” of the add-on to point to a local LT server, as described in the link above under “Offline use”.


(Kevin Schafer) #7

I’m unable to install LT in Firefox. I receive a popup message at the top of the Add-ons Manager that reads, “This add-on could not be installed because it appears to be corrupt.”


(Daniel Naber) #8

Which version of Firefox do you use?


(Kevin Schafer) #9

I did have 64.0, current version, then I tried 60.4.0. Neither of the two will take the add-on for me.

I must say, I may be doing it incorrectly. I’m opening up the Add-ons Manager, then dragging the languagetool-server (.jar) into the window. That’s when I receive the corrupt message.


(Daniel Naber) #10

Please go to https://addons.mozilla.org/firefox/addon/languagetool/ and install the add-on from that page. The .jar is a different component, it cannot be installed in Firefox. It needs to run on your computer and the add-on will communicate with it.


(Kevin Schafer) #11

I have visited that link many times and I just don’t see an add-on download. There’s a download button for Firefox. I have a Zip folder for LT 4.4 on my desktop that I have downloaded after following a link from the page link that you have provided.


(Daniel Naber) #12

Click the blue “Add to Firefox” button:

If that doesn’t show up for you, your browser might not be the original Firefox or is not detected as such.


(Kevin Schafer) #13

I’m using Chrome on my Internet computer and here is a screenshot of what I see when visiting the LT add-on page. I’m using Firefox on my offline computer. I guess herein lies the problem. There doesn’t appear to be a way of downloading the add-on unless I go online with my other computer that has Firefox.


(Kevin Schafer) #14

Okay, I have the LT add-on installed on Firefox and I’ve changed the server URL to http://localhost:8081/v2 – languagetool.jar is running.

Is there anything else that I need to do?

Thanks,
kms


(Daniel Naber) #15

Please don’t start languagetool.jar but languagetool-server.jar, as documented at https://addons.mozilla.org/firefox/addon/languagetool/


(Kevin Schafer) #16

I’m using Administrator: cmd on my computer. When typing in the command line, do I need to replace the asterix with a file path?


(Kevin Schafer) #17

Daniel,

I’m making some headway. Here is a screenshot after running the java command. Is there a test that I can conduct to see if it is working? I typed some text into my browser and nothing detected an intentional typo. I used a .bat file named “load” to start it. I used PAUSE in the .bat file so I could see what was happening.


(Daniel Naber) #18

I cannot test under Windows, but maybe you need to use this parameter instead: --allow-origin '*' (note the different type of quotes).


(Kevin Schafer) #19

I did utilize the single quotes without success. I then loaded LT 3.2 rather than 4.4. I think it worked, as there are no problems stated regarding the database.

I’m using CKEditor for my textarea. I believe it’s very similar to TinyMCE. I don’t see any signs of LT working just yet. I do have spell check enabled in my browser options, and in the upper right-hand corner of the browser it shows that LT is ready.

I also included a screenshot so you can see if I have the url correct.

url_screenshot


(Kevin Schafer) #20

I’m getting a little blue icon with a floating wave motion in the lower right-hand corner of my text editor – after I click on “Source” and view my text that way. A misspelled word doesn’t get highlighted yet at this time.

It appears that LT is disabled in rich text mode.